grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026ó ~7ìAMf¥ôãóJ•SrSrSSKrSrSr"SS\5r"SS \5rS rS2S jr S r S r Sr Sr SrSrSrSrSrSr"SS5rSq\R,"SS\55r\R,"SS\55r"SS5r\\l"SS5r"S S!\\5r"S"S#\5r"S$S%\\5r"S&S'5r\\l\\l"S(S)5r "S*S+\ \5r!"S,S-\!5r""S.S/\ \5r#"S0S15r$\$\!l\$\#lg)3z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€có•\rSrSrSrSrg)ÚAddressValueErroréz%A Value Error related to the address.©N©Ú__name__Ú __module__Ú __qualname__Ú__firstlineno__Ú__doc__Ú__static_attributes__róÚ0/opt/alt/python313/lib64/python3.13/ipaddress.pyrró†Ü/rrcó•\rSrSrSrSrg)ÚNetmaskValueErroréz%A Value Error related to the netmask.rNr rrrrrrrrcó¨•[U5$![[4a Of=f[U5$![[4a Of=f[ U<S35e)a†Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z. does not appear to be an IPv4 or IPv6 address)Ú IPv4AddressrrÚ IPv6AddressÚ ValueError©Úaddresss rÚ ip_addressrsg€ð  ܘ7Ó#Ð#øÜ Ô0Ð 1ó Ù ð úð ܘ7Ó#Ð#øÜ Ô0Ð 1ó Ù ð úô ˜‘{Ð"PÐQÓ RÐRó‚ � Ÿ ¤ /¯AÁAcó¨•[X5$![[4a Of=f[X5$![[4a Of=f[ U<S35e)a¨Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z. does not appear to be an IPv4 or IPv6 network)Ú IPv4NetworkrrÚ IPv6Networkr)rÚstricts rÚ ip_networkr"9sg€ð  ܘ7Ó+Ð+øÜ Ô0Ð 1ó Ù ð úð ܘ7Ó+Ð+øÜ Ô0Ð 1ó Ù ð úô ˜‘{Ð"PÐQÓ RÐRrcó¨•[U5$![[4a Of=f[U5$![[4a Of=f[ U<S35e)a/Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z0 does not appear to be an IPv4 or IPv6 interface)Ú IPv4InterfacerrÚ IPv6Interfacerrs rÚ ip_interfacer&Vsg€ð* ܘWÓ%Ð%øÜ Ô0Ð 1ó Ù ð úð ܘWÓ%Ð%øÜ Ô0Ð 1ó Ù ð úô ˜‘{Ð"RÐSÓ TÐTrcóX•URS5$![a [S5ef=f)a@Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éz&Address negative or too large for IPv4©Úto_bytesÚ OverflowErrorrrs rÚv4_int_to_packedr,xs6€ðCØ×Ñ Ó"Ð"øÜ óCÜÐAÓBÐBðCúó‚“)cóX•URS5$![a [S5ef=f)záRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. éz&Address negative or too large for IPv6r)rs rÚv6_int_to_packedr0Œs6€ðCØ×Ñ Ó#Ð#øÜ óCÜÐAÓBÐBðCúr-cóv•[U5RS5n[U5S:”a[SU<35eU$)zAHelper to split the netmask and raise AddressValueError if neededÚ/ézOnly one '/' permitted in )ÚstrÚsplitÚlenr)rÚaddrs rÚ_split_optional_netmaskr8œs9€ä ˆw‹<× Ñ ˜cÓ "€DÜ ˆ4ƒy�1ƒ}ÜÐ"<¸W¹KÐ HÓIÐIØ €Krc#ó¢# •[U5n[U5=p#UH)nURURS-:waX#4v• UnUnM+ X#4v• g7f)z»Find a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. éN)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚips rÚ_find_address_rangerC¤sVé€ô ˆi‹€Bܘ“8ЀEÛˆØ �6‰6�T—X‘X ‘\Ó !Ø�+Ò ØˆEØŠñ ð ˆ+Óùs‚A AcóR•US:XaU$[X)US- -R55$)zÍCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr:)ÚminÚ bit_length)ÚnumberÚbitss rÚ_count_righthand_zero_bitsrI¸s/€ð�ƒ{؈ Ü ˆt�g ¨¡Ñ*×6Ñ6Ó8Ó 9Ð9rc#ór# •[U[5(a[U[5(d [S5eURUR:wa[U<SU<S35eX:”a [ S5eURS:Xa[ nO"URS:Xa[ nO [ S5eURnURnURnXE::a_[[XC5XT- S-R5S- 5nU"XCU- 45nUv• USU-- nUS- UR:Xag XE::aM^g g 7f) aXSummarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksú and ú are not of the same versionz*last IP address must be greater than firstr(ézunknown IP versionr:N) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrr Ú_max_prefixlenr=rErIrFÚ _ALL_ONES)r@rArBÚip_bitsÚ first_intÚlast_intÚnbitsÚnets rÚsummarize_address_rangerYÈs!é€ô4˜œ|× ,Ñ ,Ü ˜œl× +Ñ +ÜÐKÓLÐLØ ‡}�}˜Ÿ ™ Ó$ÜÛ£ð&ó'ð 'à ƒ|ÜÐEÓFÐFà ‡}�}˜ÓÜ ‰Ø �‰˜!Ó Ü ‰äÐ-Ó.Ð.à×"Ñ"€GØ— ‘ €IØ�x‰x€HØ Ó ÜÔ.¨yÓBØÑ)¨AÑ-×9Ñ9Ó;¸aÑ?óAˆá�) u™_Ð-Ó.ˆØŠ Ø�Q˜%‘Zш Ø �q‰=˜BŸL™LÓ (Ø ð × ùs ‚D1D7Ä5D7c#óv# •[U5n0nU(aZUR5nUR5nURU5nUcX2U'OXS:waX$ UR U5 U(aMZSn[ UR 55H(nUbURUR:¼aM"Uv• UnM* g7f)a9Loops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r>Úto_mergeÚsubnetsrXr]ÚexistingrAs rÚ_collapse_addresses_internalrfÿs®é€ô2�I‹€HØ€GÞ Ø�l‰l‹nˆØ—<‘<“>ˆØ—;‘;˜xÓ(ˆØ Ñ Ø #�HÒ Ø ‹_àÐ!Ø �O‰O˜HÔ %÷ ˆ(ð €DÜ�g—n‘nÓ&Ö'ˆØ Ñ ð×%Ñ%¨×)>Ñ)>Ó>ÙØŠ ØŠò(ùs ‚A-B9Á1AB9cóh•/n/n/nUGH#n[U[5(aMU(a3USRUR:wa[U<SUS<S35eUR U5 MfUR UR :XaXU(a3USRUR:wa[U<SUS<S35eUR UR5 MØU(a3USRUR:wa[U<SUS<S35eUR U5 GM& [[U55nU(a.[U5HupVUR[XV55 M! [X-5$![a UR UR5 GM§f=f)aŸCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterable of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. éÿÿÿÿrKrL)rNrOÚ_versionrPr_Ú _prefixlenrRrBÚAttributeErrorÚnetwork_addressr`ÚsetrCÚextendrYrf)r>ÚaddrsÚipsÚnetsrBr@rAs rÚcollapse_addressesrr0sq€ð$ €EØ €CØ €DôˆÜ �bœ,× 'Ñ 'Þ�s˜2‘w×'Ñ'¨2¯;©;Ó6ÜÛ!# S¨¤Wð!.ó/ð/à �J‰J�rŽNØ �]‰]˜b×/Ñ/Ó /Þ�s˜2‘w×'Ñ'¨2¯;©;Ó6ÜÛ!# S¨¤Wð!.ó/ð/ð /Ø— ‘ ˜2Ÿ5™5Ö!ö˜˜R™×)Ñ)¨R¯[©[Ó8ÜÛ!# T¨"¤Xð!/ó0ð0à �K‰K˜�Oñ%ô* ”�S“Ó €Cö Ü.¨sÖ3‰KˆEØ �L‰LÔ0°Ó=Ö >ñ4ô (¨© Ó 5Ð5øô!"ó /Ø— ‘ ˜2×-Ñ-×.Ð.ð /úsÃFÆ%F1Æ0F1có¢•[U[5(aUR5$[U[5(aUR 5$[ $)aReturn a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )rNÚ _BaseNetworkÚ_get_networks_keyrOÚ_get_address_keyÚNotImplemented)Úobjs rÚget_mixed_type_keyryfsB€ô$�#”|×$Ñ$Ø×$Ñ$Ó&Ð&Ü �Cœ× &Ñ &Ø×#Ñ#Ó%Ð%Ü ÐrcóΕ\rSrSrSrSr\S5r\S5r\S5r \S5r Sr S r \ S 5r\ S 5r\ S 5r\ S 5r\ S5r\ S5rSrSrg)Ú_IPAddressBaseizThe mother class.rcó"•UR5$)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string©Úselfs rÚexplodedÚ_IPAddressBase.exploded…s€ð×0Ñ0Ó2Ð2rcó•[U5$)z;Return the shorthand version of the IP address as a string.©r4r~s rÚ compressedÚ_IPAddressBase.compressedŠs€ô�4‹yÐrcó"•UR5$)aThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointerr~s rÚreverse_pointerÚ_IPAddressBase.reverse_pointer�s€ð×$Ñ$Ó&Ð&rcó6•S[U54-n[U5e)Nz%200s has no version specified©ÚtypeÚNotImplementedError©rÚmsgs rrQÚ_IPAddressBase.versionšs€à.´$°t³*°Ñ>ˆÜ! #Ó&Ð&rcó°•US:aSn[X!UR4-5eXR:”a&Sn[X!URUR4-5eg)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrirSrR)rrr�s rÚ_check_int_addressÚ!_IPAddressBase._check_int_addressŸsa€Ø �Q‹;ØAˆCÜ# C°D·M±MÐ*BÑ$BÓCÐ CØ —^‘^Ó #ØFˆCÜ# C°D×4GÑ4GØ+/¯=©=ð+:ñ%:ó;ð ;ð $rcó\•[U5nX2:waSn[XAUX R4-5eg)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r6rri)rrÚ expected_lenÚ address_lenr�s rÚ_check_packed_addressÚ$_IPAddressBase._check_packed_address¨sA€Ü˜'“lˆ Ø Ó &ØJˆCÜ# C°KØ+7¿¹ð+Hñ%HóIð Ið 'rcó:•URURU- - $)z~Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )rS)ÚclsÚ prefixlens rÚ_ip_int_from_prefixÚ"_IPAddressBase._ip_int_from_prefix¯s€ð�}‰} § ¡ °Ñ :Ñ;Ð;rcóÒ•[UUR5nURU- nX- nSU-S- nXE:wa0URS-nURUS5nSn[X‡-5eU$)zãReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r:éÚbigz&Netmask pattern %r mixes zeroes & ones)rIrRr*r) ršÚip_intÚtrailing_zeroesr›Ú leading_onesÚall_onesÚbyteslenÚdetailsr�s rÚ_prefix_from_ip_intÚ"_IPAddressBase._prefix_from_ip_int¼s~€ô5°VØ58×5GÑ5GóIˆà×&Ñ&¨Ñ8ˆ ØÑ0ˆ ؘ‘N aÑ'ˆØ Ó #Ø×)Ñ)¨QÑ.ˆHØ—o‘o h°Ó6ˆGØ:ˆCܘS™]Ó+Ð +ØÐrcó$•SU-n[U5Se)Nz%r is not a valid netmask)r)ršÚ netmask_strr�s rÚ_report_invalid_netmaskÚ&_IPAddressBase._report_invalid_netmaskÕs€à)¨KÑ7ˆÜ Ó$¨$Ð.rcó*•UR5(aUR5(dURU5 [U5nSWs=::aUR ::dO URU5 U$![a URU5 NIf=f)zÑReturn prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)ÚisasciiÚisdigitr«ÚintrrR)ršÚ prefixlen_strr›s rÚ_prefix_from_prefix_stringÚ)_IPAddressBase._prefix_from_prefix_stringÚs†€ð×%Ñ%×'Ñ'¨M×,AÑ,A×,CÑ,CØ × 'Ñ '¨ Ô 6ð 7ܘMÓ*ˆIð�YÕ4 #×"4Ñ"4Õ4Ø × 'Ñ '¨ Ô 6ØÐøô ó 7Ø × 'Ñ '¨ Ö 6ð 7ús½ A4Á4BÂBcó0•URU5nURW5$![a URU5 N/f=f![a Of=fWUR -nURU5$![a URU5 gf=f)zæTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrr«r§rrS)ršÚip_strr¡s rÚ_prefix_from_ip_stringÚ%_IPAddressBase._prefix_from_ip_stringós¢€ð 0Ø×,Ñ,¨VÓ4ˆFð Ø×*Ñ*¨6Ó2Ð 2øô!ó 0Ø × 'Ñ '¨Ö /ð 0ûôó Ù ð úð �#—-‘-шð 0Ø×*Ñ*¨6Ó2Ð 2øÜó 0Ø × 'Ñ '¨Ö /ð 0ús2‚%”A¥AÁAÁ AÁAÁ&A7Á7BÂBcóÖ•[U[[45(a XR4$[U[5(d [ U5n[ U5S:”aU$USUR4$)z�Helper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. r:r)rNÚbytesr°rRÚtupler8r6)ršrs rÚ_split_addr_prefixÚ!_IPAddressBase._split_addr_prefixse€ô �g¤¤s˜|× ,Ñ ,Ø×.Ñ.Ð.Ð .ä˜'¤5×)Ñ)ô.¨gÓ6ˆGô ˆw‹<˜!Ó ØˆNØ�q‰z˜3×-Ñ-Ð-Ð-rcó2•UR[U544$©N©Ú __class__r4r~s rÚ __reduce__Ú_IPAddressBase.__reduce__-s€Ø�~‰~¤ D£ ˜|Ð+Ð+rN)r r r r rÚ __slots__Úpropertyr€r„rˆrQr’r—Ú classmethodrœr§r«r²r·r¼rÂrrrrr{r{sá†áà€Ià ñ3óð3ðñóððñ'óð'ðñ'óð'ò;òIðñ <óð <ðñóðð0ñ/óð/ðñóðð0ñ0óð0ðBñ.óð.õ.,rr{cól^•\rSrSrSrSrSrSrSrSr Sr S r S r S r S rS rU4SjrSrU=r$)rOi3ztA generic IP object. This IP class contains the version independent methods which are used by single IP addresses. rcó•UR$r¿©r=r~s rÚ__int__Ú_BaseAddress.__int__>s €Ø�x‰xˆrcó¢•URUR:H=(a URUR:H$![a [s$f=fr¿)r=rirkrw©rÚothers rÚ__eq__Ú_BaseAddress.__eq__AsF€ð "Ø—H‘H § ¡ Ñ)÷8ØŸ ™ ¨¯©Ñ7ð 9øäó "Ü!Ò !ð "ús‚8;»AÁ Acóú•[U[5(d[$URUR:wa[ U<SU<S35eUR UR :waUR UR :$g©NrKrLF)rNrOrwrirPr=rÍs rÚ__lt__Ú_BaseAddress.__lt__Hsb€Ü˜%¤×.Ñ.Ü!Ð !Ø �=‰=˜EŸN™NÓ *ÜÛ!£5ð*ó+ð +à �8‰8�u—y‘yÓ Ø—8‘8˜eŸi™iÑ'Ð 'Ørcór•[U[5(d[$UR[U5U-5$r¿©rNr°rwrÁrÍs rÚ__add__Ú_BaseAddress.__add__Tó-€Ü˜%¤×%Ñ%Ü!Ð !Ø�~‰~œc $›i¨%Ñ/Ó0Ð0rcór•[U[5(d[$UR[U5U- 5$r¿rÖrÍs rÚ__sub__Ú_BaseAddress.__sub__YrÙrcóP•URR<S[U5<S3$©NÚ(Ú)©rÁr r4r~s rÚ__repr__Ú_BaseAddress.__repr__^ó€ØŸ>™>×2Ô2´C¸¶IÐ>Ð>rcóJ•[URUR55$r¿)r4Ú_string_from_ip_intr=r~s rÚ__str__Ú_BaseAddress.__str__as€Ü�4×+Ñ+¨D¯H©HÓ5Ó6Ð6rcóP•[[[UR555$r¿)ÚhashÚhexr°r=r~s rÚ__hash__Ú_BaseAddress.__hash__ds€Ü”Cœ˜DŸH™H› Ó&Ó'Ð'rcó•URU4$r¿©rir~s rrvÚ_BaseAddress._get_address_keygs€Ø— ‘ ˜tÐ$Ð$rcó4•URUR44$r¿)rÁr=r~s rrÂÚ_BaseAddress.__reduce__js€Ø�~‰~ §¡˜{Ð*Ð*rcóò>•U(a USS:Xa[[U5U5$[cSSKnUR S5q[R U5nU(d[ TU]U5$UR5upEnUS:XaURS:XaSnOS nUS:Xa URnOURS-nU(a XwS-S - - nU(aUS - n[[U5US UUU35$) a°Returns an IP address as a formatted string. Supported presentation types are: 's': returns the IP address as a string (default) 'b': converts to binary and returns a zero-padded string 'X' or 'x': converts to upper- or lower-case hex and returns a zero-padded string 'n': the same as 'b' for IPv4 and 'x' for IPv6 For binary and hex presentation types, the alternate form specifier '#' and the grouping option '_' are supported. rhÚsNrz(#?)(_?)([xbnX])Únr(ÚbÚxr:r3Ú0) Úformatr4Ú_address_fmt_reÚreÚcompileÚ fullmatchÚsuperÚ __format__ÚgroupsrirRr°) rÚfmtrûÚmÚ alternateÚgroupingÚfmt_baseÚpadlenrÁs €rrÿÚ_BaseAddress.__format__msôø€ö�c˜"‘g “nÜœ#˜d›) SÓ)Ð )ô Ñ "Û Ø Ÿj™jÐ);Ó<ˆOä × %Ñ % cÓ *ˆÞÜ‘7Ñ% cÓ*Ð *à()¯©« Ñ%ˆ ˜Xð �s‹?Ø�}‰} Ó!Ø‘à�à �s‹?Ø×(Ñ(‰Fà×(Ñ(¨AÑ-ˆFæ Ø  ‘k A‘oÑ %ˆFæ Ø �a‰KˆFä”c˜$“i I ;¨a°¨x¸°zÀ(ÀÐ!LÓMÐMr)r r r r rrÄrÊrÏrÓr×rÛrârçrìrvrÂrÿrÚ __classcell__©rÁs@rrOrO3sMø†ñð €Iòò"òò1ò 1ò ?ò7ò(ò%ò+÷/Nó/NrrOcó®•\rSrSrSrSrSrSrSrSr Sr S r S r S r S r\R S 5r\R S5r\S5r\S5r\S5r\S5r\S5r\S5rSrSrSrS&SjrS&Sjr\S5r\ S5r!Sr"Sr#\S5r$\S 5r%\S!5r&\S"5r'\S#5r(\S$5r)S%r*g)'rtiŸzqA generic IP network object. This IP class contains the version independent methods which are used by networks. cóP•URR<S[U5<S3$rÞrár~s rrâÚ_BaseNetwork.__repr__§rärcó8•SURUR4-$©Nú%s/%d)rlr›r~s rrçÚ_BaseNetwork.__str__ªs€Ø˜$×.Ñ.°·±Ð?Ñ?Ð?rc#ó²# •[UR5n[UR5n[US-U5HnUR U5v• M g7f)z‡Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r:N©r°rlrbÚrangeÚ_address_class©rÚnetworkÚ broadcastr÷s rÚhostsÚ_BaseNetwork.hosts­sMé€ô�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ü�w ‘{ IÖ.ˆAØ×%Ñ% aÓ(Ô (ò/ùs‚AAc#ó°# •[UR5n[UR5n[XS-5HnUR U5v• M g7f)Nr:rrs rÚ__iter__Ú_BaseNetwork.__iter__¹sIé€Ü�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ü�w¨A¡ Ö.ˆAØ×%Ñ% aÓ(Ô (ò/ùs‚AAcó•[UR5n[UR5nUS:¼a&X!-U:”a [S5eUR X!-5$US- nX1-U:a [S5eUR X1-5$)Nrzaddress out of ranger:)r°rlrbÚ IndexErrorr)rrõrrs rÚ __getitem__Ú_BaseNetwork.__getitem__¿s„€Ü�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ø �‹6؉{˜YÓ&Ü Ð!7Ó8Ð8Ø×&Ñ& w¡{Ó3Ð 3à �‰FˆA؉}˜wÓ&Ü Ð!7Ó8Ð8Ø×&Ñ& y¡}Ó5Ð 5rcó`•[U[5(d[$URUR:wa[ U<SU<S35eUR UR :waUR UR :$UR UR :waUR UR :$grÒ)rNrtrwrirPrlÚnetmaskrÍs rrÓÚ_BaseNetwork.__lt__Ìs�€Ü˜%¤×.Ñ.Ü!Ð !Ø �=‰=˜EŸN™NÓ *ÜÛ!£5ð*ó+ð +à × Ñ  5×#8Ñ#8Ó 8Ø×'Ñ'¨%×*?Ñ*?Ñ?Ð ?Ø �<‰<˜5Ÿ=™=Ó (Ø—<‘< %§-¡-Ñ/Ð /Ørcó•URUR:H=(aK URUR:H=(a+ [UR5[UR5:H$![a [ s$f=fr¿)rirlr°r"rkrwrÍs rrÏÚ_BaseNetwork.__eq__Øsk€ð "Ø—M‘M U§^¡^Ñ3÷<Ø×(Ñ(¨E×,AÑ,AÑA÷<䘟 ™ Ó%¬¨U¯]©]Ó);Ñ;ð =øôó "Ü!Ò !ð "ús‚A*A-Á-BÁ?Bcóh•[[UR5[UR545$r¿)rêr°rlr"r~s rrìÚ_BaseNetwork.__hash__às&€Ü”S˜×-Ñ-Ó.´°D·L±LÓ0AÐBÓCÐCrcóØ•URUR:wag[U[5(agURURR-UR R:H$©NF)rirNrtr=r"rlrÍs rÚ __contains__Ú_BaseNetwork.__contains__ãsQ€à �=‰=˜EŸN™NÓ *Øä �eœ\× *Ñ *Øð—9‘9˜tŸ|™|×/Ñ/Ñ/°4×3GÑ3G×3KÑ3KÑKÐ Krcó¤•URU;=(d; URU;=(d% URU;=(d URU;$)z*Tell if self is partly contained in other.©rlrbrÍs rÚoverlapsÚ_BaseNetwork.overlapsïsN€à×#Ñ# uÑ,÷7Ø × "Ñ " eÑ +÷ 6Ø×%Ñ%¨Ñ-÷5Ø×+Ñ+¨tÑ3ð 7rcóv•UR[UR5[UR5-5$r¿)rr°rlÚhostmaskr~s rrbÚ_BaseNetwork.broadcast_addressös3€à×"Ñ"¤3 t×';Ñ';Ó#<Ü#& t§}¡}Ó#5ñ$6ó7ð 7rcód•UR[UR5UR- 5$r¿)rr°r"rSr~s rr1Ú_BaseNetwork.hostmaskûs%€à×"Ñ"¤3 t§|¡|Ó#4°t·~±~Ñ#EÓFÐFrcó8•SURUR4-$r)rlrjr~s rÚwith_prefixlenÚ_BaseNetwork.with_prefixlenÿs€à˜$×.Ñ.°·±Ð@Ñ@Ð@rcó<•UR<SUR<3$©Nr2)rlr"r~s rÚ with_netmaskÚ_BaseNetwork.with_netmasks€à×.Ô.°· ³ Ð=Ð=rcó<•UR<SUR<3$r9)rlr1r~s rÚ with_hostmaskÚ_BaseNetwork.with_hostmasks€à×.Ô.°· ³ Ð>Ð>rcó^•[UR5[UR5- S-$)z&Number of hosts in the current subnet.r:)r°rbrlr~s rÚ num_addressesÚ_BaseNetwork.num_addresses s*€ô�4×)Ñ)Ó*¬S°×1EÑ1EÓ-FÑFÈÑJÐJrcó6•S[U54-n[U5e)Nz%%200s has no associated address classr‹rŽs rrÚ_BaseNetwork._address_classs€ð 6¼¸d»¸ ÑEˆÜ! #Ó&Ð&rcó•UR$r¿)rjr~s rr›Ú_BaseNetwork.prefixlens €à�‰Ðrc#óæ# •URUR:Xd[U<SU<S35e[U[5(d[SU-5eUR U5(d[ U<SU<35eX:XagUR UR<SUR<35nUR5up#X!:wa‚X1:wa}UR U5(aUv• UR5up#ODUR U5(aUv• UR5up#O[SU<SU<S U<35eX!:waX1:waM}X!:XaUv• gX1:XaUv• g[SU<SU<S U<35e7f) aêRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. rKrLz%s is not a network objectz not contained in Nr2z Error performing exclusion: s1: z s2: z other: ) rirPrNrtÚ subnet_ofrrÁrlr›rdÚAssertionError)rrÎÚs1Ús2s rÚaddress_excludeÚ_BaseNetwork.address_excludesOé€ðH�}‰} §¡Ó.ÜÛ!£5ð*ó+ð +ô˜%¤×.Ñ.ÜÐ8¸5Ñ@ÓAÐ Aà�‰˜t×$Ñ$Ü»ÂÐEÓFÐ FØ ‹=Ø ð—‘¨5×+@Ô+@Ø+0¯?«?ð!<ó=ˆð—‘“‰ˆØ‹k˜b›kØ�‰˜r×"Ñ"ؒ؟™›‘��BØ—‘ ×$Ñ$ؒ؟™›‘��Bõ%ã&(«"ªeð&5ó6ð6ð‹k˜b�kð ‹;Ø‹HØ ‹[Ø‹Hõ!ã"$£bª%ð"1ó2ð 2ùs ‚EE1Å+E1có6•URUR:wa[U<SU<S35eURUR:agURUR:”agURUR:agURUR:”agg)aåCompare two IP objects. This is only concerned about the comparison of the integer representation of the network addresses. This means that the host bits aren't considered at all in this method. If you want to compare host bits, you can easily enough do a 'HostA._ip < HostB._ip' Args: other: An IP object. Returns: If the IP versions of self and other are the same, returns: -1 if self < other: eg: IPv4Network('192.0.2.0/25') < IPv4Network('192.0.2.128/25') IPv6Network('2001:db8::1000/124') < IPv6Network('2001:db8::2000/124') 0 if self == other eg: IPv4Network('192.0.2.0/24') == IPv4Network('192.0.2.0/24') IPv6Network('2001:db8::1000/124') == IPv6Network('2001:db8::1000/124') 1 if self > other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. rKz are not of the same typerhr:r)rirPrlr"rÍs rÚcompare_networksÚ_BaseNetwork.compare_networksgs…€ðB �=‰=˜EŸN™NÓ *ÜÛ!£5ð*ó+ð +ð × Ñ  %×"7Ñ"7Ó 7ØØ × Ñ  %×"7Ñ"7Ó 7Øà �<‰<˜%Ÿ-™-Ó 'ØØ �<‰<˜%Ÿ-™-Ó 'ØØrcóH•URURUR4$)z«Network-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rirlr"r~s rruÚ_BaseNetwork._get_networks_key—s€ð— ‘ ˜t×3Ñ3°T·\±\ÐBÐBrNc#ó # •URUR:XaUv• gUb9X R:a [S5eUS:wa [S5eX R- nUS:a [S5eURU-nX0R:”a[SX04-5e[UR5n[UR 5S-n[UR 5S-U- n[XEU5HnURXs45nUv• M g7f)a;The subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr:ú(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rjrRrr°rlrbr1rrÁ) rÚprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepÚnew_addrÚcurrents rrdÚ_BaseNetwork.subnets¡sé€ð4 �?‰?˜d×1Ñ1Ó 1ØŠJØ à Ñ !ØŸO™OÓ+Ü Ð!<Ó=Ð=Ø Ó"Ü Ð!KÓLÐLØ'¯/©/Ñ9ˆNà ˜AÓ ÜÐ=Ó>Ð >ØŸ™¨.Ñ8ˆ à ×.Ñ.Ó .ÜØBØ!ðF)ñ)ó*ð *ô�D×(Ñ(Ó)ˆÜ�$×(Ñ(Ó)¨AÑ-ˆÜ�D—M‘MÓ" QÑ&¨>Ñ9ˆÜ˜e¨$Ö/ˆHØ—n‘n hÐ%>Ó?ˆGØŒMò0ùs‚D Dcó|•URS:XaU$Ub:X R:”a [S5eUS:wa [S5eURU- nURU- nUS:a[SURU4-5eUR[ UR 5[ UR 5U--U45$)aSThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rznew prefix must be shorterr:rSz;current prefixlen is %d, cannot have a prefixlen_diff of %d)rjrr›rÁr°rlr")rrTrUrVs rr]Ú_BaseNetwork.supernetÖsÆ€ð* �?‰?˜aÓ ØˆKà Ñ !ØŸO™OÓ+Ü Ð!=Ó>Ð>Ø Ó"Ü Ð!KÓLÐLØ!Ÿ_™_¨zÑ9ˆNàŸ™¨Ñ7ˆ Ø ˜1Ó ÜØMØ—‘ Ð0ñ1ó2ð 2ð�~‰~Ü �×$Ñ$Ó %¬¨T¯\©\Ó):¸nÑ)LÑ MØ ðóð rcóh•URR=(a URR$©z›Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rlÚ is_multicastrbr~s rraÚ_BaseNetwork.is_multicastÿs,€ð×$Ñ$×1Ñ1÷4Ø×&Ñ&×3Ñ3ð 5rcó •URUR:wa[USUS35eURUR:*=(a URUR:¬$![a [SUSU35ef=f)NrKrLz*Unable to test subnet containment between )rirPrlrbrk)Úarös rÚ _is_subnet_ofÚ_BaseNetwork._is_subnet_of s”€ð 4à�z‰z˜QŸZ™ZÓ'Ü 1 # U¨1¨#Ð-IÐ JÓKÐKØ×%Ñ%¨×):Ñ):Ñ:÷?Ø×'Ñ'¨1×+>Ñ+>Ñ>ð @øäó 4Üð'Ø'( c¨¨q¨cð3ó4ð 4ð 4ús ‚A#A&Á&Bcó$•URX5$)z1Return True if this network is a subnet of other.©rerÍs rrGÚ_BaseNetwork.subnet_ofs€à×!Ñ! $Ó.Ð.rcó$•URX5$)z3Return True if this network is a supernet of other.rhrÍs rÚ supernet_ofÚ_BaseNetwork.supernet_ofs€à×!Ñ! %Ó.Ð.rcóh•URR=(a URR$)ú•Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )rlÚ is_reservedrbr~s rroÚ_BaseNetwork.is_reservedó,€ð×$Ñ$×0Ñ0÷3Ø×&Ñ&×2Ñ2ð 4rcóh•URR=(a URR$©zxTest if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rlÚ is_link_localrbr~s rrtÚ_BaseNetwork.is_link_local+s,€ð×$Ñ$×2Ñ2÷5Ø×&Ñ&×4Ñ4ð 6rcó¶^•[U4SjTRR55=(a) [U4SjTRR55$)z­Test if this network belongs to a private range. Returns: A boolean, True if the network is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. c3ón># •UH*nTRU;=(a TRU;v• M, g7fr¿r-)Ú.0Ú priv_networkrs €rÚ Ú*_BaseNetwork.is_private..?s<øé€ðJâ'H�|ð×'Ñ'¨<Ñ7÷:Ø×)Ñ)¨\Ñ9ô:â'Hùóƒ25c3ón># •UH*nTRU;=(a TRU;v• M, g7fr¿r-)rxrrs €rrzr{As?øé€ðRò$P˜ð×(Ñ(°Ñ7÷:Ø×*Ñ*°'Ñ9ô:â#Oùr|©ÚanyÚ _constantsÚ_private_networksÚallÚ_private_networks_exceptionsr~s`rÚ is_privateÚ_BaseNetwork.is_private6sUø€ôôJà'+§¡×'HÒ'HóJóJ÷äNQôRð$(§?¡?×#OÒ#OóRóOð rcó$•UR(+$)z·Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )r„r~s rÚ is_globalÚ_BaseNetwork.is_globalGs€ð—?‘?Ô"Ð"rcóh•URR=(a URR$)úˆTest if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )rlÚis_unspecifiedrbr~s rr‹Ú_BaseNetwork.is_unspecifiedRs,€ð×$Ñ$×3Ñ3÷6Ø×&Ñ&×5Ñ5ð 7rcóh•URR=(a URR$)ú‘Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )rlÚ is_loopbackrbr~s rr�Ú_BaseNetwork.is_loopback^rqrr)r:N)+r r r r rrârçrrrrÓrÏrìr*r.Ú functoolsÚcached_propertyrbr1rÅr6r:r=r@rr›rKrNrurdr]raÚ staticmethodrerGrkrortr„r‡r‹r�rrrrrtrtŸs·†ñò ?ò@ò )ò)ò 6ò ò"òDò Lò7ð×Ññ7óð7ð×ÑñGóðGðñAóðAðñ>óð>ðñ?óð?ðñKóðKðñ'óð'ðñóðòI2òV.ò`Cô3ôj'ðRñ 5óð 5ðñ 4óð 4ò/ò/ðñ 4óð 4ðñ6óð6ðñóðð ñ#óð#ðñ 7óð 7ðñ 4óó 4rrtcó•\rSrSr/rSrg)Ú_BaseConstantsikrN)r r r r r�rrrrr•r•ks†àÓrr•có¤•\rSrSrSrSrSrS\-S- r\r 0r Sr \ S5r \ S 5r\ S 5r\ S 5rS r\S 5r\S5rSrg)Ú_BaseV4iszmBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. rr(r3r:có•[U5$r¿rƒr~s rr}Ú$_BaseV4._explode_shorthand_ip_string†s €Ü�4‹yÐrcó|•XR;a~[U[5(a-UnSUs=::aUR::dO UR U5 OUR U5n[URU55nX24URU'URU$![ a URU5nNVf=f©zçMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r) Ú_netmask_cacherNr°rRr«r²rr·rrœ©ršÚargr›r"s rÚ _make_netmaskÚ_BaseV4._make_netmask‰sº€ð ×(Ñ(Ó (ܘ#œs×#Ñ#Ø� ؘYÕ<¨#×*<Ñ*<Õ<Ø×/Ñ/° Ô:øð@à #× >Ñ >¸sÓ C�Iô " #×"9Ñ"9¸)Ó"DÓEˆGØ&-Ð&8ˆC× Ñ ˜sÑ #Ø×!Ñ! #Ñ&Ð&øô )ó@ð!$× :Ñ :¸3Ó ?’Ið@úsÁBÂB;Â:B;có"•U(d [S5eURS5n[U5S:wa[SU-5e[R [ UR U5S5$![an[U<SU<35SeSnAff=f)z×Turn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. úAddress cannot be emptyÚ.r(zExpected 4 octets in %rr ú in N)rr5r6r°Ú from_bytesÚmapÚ _parse_octetr)ršr¶ÚoctetsÚexcs rrµÚ_BaseV4._ip_int_from_string£s†€öÜ#Ð$=Ó>Ð >à—‘˜cÓ"ˆÜ ˆv‹;˜!Ó Ü#Ð$=ÀÑ$FÓGÐ Gð JÜ—>‘>¤# c×&6Ñ&6¸Ó"?ÀÓGÐ GøÜó JÜ#³#²vÐ$>Ó?ÀTÐ Iûð JúsÁ)A,Á, BÁ6B  BcóT•U(d [S5eUR5(aUR5(dSn[X!-5e[U5S:”aSn[X!-5eUS:waUSS:XaSn[X!-5e[ US5nUS :”a[S U-5eU$) zÔConvert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %rrørz%Leading zeros are not permitted in %ré éÿzOctet %d (> 255) not permitted)rr®r¯r6r°)ršÚ octet_strr�Ú octet_ints rr§Ú_BaseV4._parse_octet½s³€öÜÐ8Ó9Ð 9à×!Ñ!×#Ñ#¨ ×(9Ñ(9×(;Ñ(;Ø7ˆCܘS™_Ó-Ð -ô ˆy‹>˜AÓ Ø8ˆCܘS™_Ó-Ð -ð ˜Ó   ¨!¡ °Ó 3Ø9ˆCܘS™_Ó-Ð -ä˜  2Ó&ˆ Ø �s‹?ÜÐ=À ÑIÓJÐ JØÐrc ó`•SR[[URSS555$)zªTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. r£r(r )Újoinr¦r4r*)ršr¡s rræÚ_BaseV4._string_from_ip_intás%€ð�x‰xœœC §¡°°EÓ!:Ó;Ó<Ð# •UH nTU;v• M g7fr¿r©rxrXrs €rrzÚ)IPv4Address.is_private..Kóøé€ÐIÒ'H �˜– Ò'Hùóƒc3ó.># •UH nTU;v• M g7fr¿rrÔs €rrzrÕLóøé€Ð\Ò/[¨�D –OÒ/[ùr×r~r~s`rr„ÚIPv4Address.is_private9s@ø€ô$ ÔI t§¡×'HÒ'HÓIÓ I÷ ]ÜÔ\¨t¯©×/[Ò/[Ó\Ó\ð rcób•XRR;=(a UR(+$©a*``True`` if the address is defined as globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exception: For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_global == address.ipv4_mapped.is_global ``is_global`` has value opposite to :attr:`is_private`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. )r€Ú_public_networkr„r~s rr‡ÚIPv4Address.is_globalOs#€ð Ÿ?™?×:Ñ:Ñ:×RÀ4Ç?Á?Ô?RÐRrcó2•XRR;$)z�Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )r€Ú_multicast_networkr~s rraÚIPv4Address.is_multicastas€ð—‘×9Ñ9Ñ9Ð9rcó2•XRR:H$)z„Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )r€Ú_unspecified_addressr~s rr‹ÚIPv4Address.is_unspecifiedls€ð—‘×;Ñ;Ñ;Ð;rcó2•XRR;$)zuTest if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )r€Ú_loopback_networkr~s rr�ÚIPv4Address.is_loopbackws€ð—‘×8Ñ8Ñ8Ð8rcó2•XRR;$)zzTest if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )r€Ú_linklocal_networkr~s rrtÚIPv4Address.is_link_local�s€ð—‘×9Ñ9Ñ9Ð9rcó•[SU35$)z_Return the IPv4-mapped IPv6 address. Returns: The IPv4-mapped IPv6 address per RFC 4291. z::ffff:)rr~s rÚ ipv6_mappedÚIPv4Address.ipv6_mapped‹s€ô˜W T FÐ+Ó,Ð,rrÉN)r r r r rrÄrÇrÅrËror‘Ú lru_cacher„r‡rar‹r�rtrìrrrrrrsè†á9à&€Iò!6ðFñ*óð*ðñ9óð9ðØ×ÒÓñ óóð ð(Ø×ÒÓñSóóðSð ñ:óð:ðñ<óð<ðñ9óð9ðñ:óð:ðñ-óó-rrcó®•\rSrSrSr\R S5rSrSr Sr Sr \ Rr \S5r\S 5r\S 5r\S 5rS rg )r$i–cóà•URU5up#[RX5 [X#4SS9UlURR UlURR Ulg©NF)r!)r¼rrÇrrr"rj©rrr7Úmasks rrÇÚIPv4Interface.__init__˜óT€Ø×,Ñ,¨WÓ5‰ ˆä×јTÔ(Ü" D <¸Ñ>ˆŒ Ø—|‘|×+Ñ+ˆŒ ØŸ,™,×1Ñ1ˆ�rcó.•URR$r¿©rr1r~s rr1ÚIPv4Interface.hostmask ó€à�|‰|×$Ñ$Ð$rcóV•SURUR5UR4-$r©rær=rjr~s rrçÚIPv4Interface.__str__¤s,€Ø˜$×2Ñ2°4·8±8Ó<ØŸ/™/ð+ñ+ð +rcó¤•[RX5nU[LdU(dU$URUR:H$![a gf=fr))rrÏrwrrk©rrÎÚ address_equals rrÏÚIPv4Interface.__eq__¨óN€Ü#×*Ñ*¨4Ó7ˆ Ø œNÒ *¶-Ø Ð ð Ø—<‘< 5§=¡=Ñ0Ð 0øÜó ñð  úó©AÁ AÁAcóð•[RX5nU[La[$URUR:=(d" URUR:H=(a U$![a gf=fr))rrÓrwrrk©rrÎÚ address_lesss rrÓÚIPv4Interface.__lt__´sj€Ü"×)Ñ)¨$Ó6ˆ Ø œ>Ò )Ü!Ð !ð Ø—L‘L 5§=¡=Ñ0÷CØ—L‘L E§M¡MÑ1×B°lð Døäó ñð ús¦AA(Á( A5Á4A5có€•[URUR[URR 545$r¿©rêr=rjr°rrlr~s rrìÚIPv4Interface.__hash__Àó+€Ü�T—X‘X˜tŸ™´°D·L±L×4PÑ4PÓ0QÐRÓSÐSrcó,•[UR5$r¿)rr=r~s rrBÚIPv4Interface.ipÅó€ä˜4Ÿ8™8Ó$Ð$rcóZ•URUR5<SUR<3$r9rûr~s rr6ÚIPv4Interface.with_prefixlenÉó%€à×2Ñ2°4·8±8Ö<ØŸ/›/ð+ð +rcóZ•URUR5<SUR<3$r9©rær=r"r~s rr:ÚIPv4Interface.with_netmaskÎó%€à×2Ñ2°4·8±8Ö<ØŸ,›,ð(ð (rcóZ•URUR5<SUR<3$r9©rær=r1r~s rr=ÚIPv4Interface.with_hostmaskÓó%€à×2Ñ2°4·8±8Ö<ØŸ-›-ð)ð )r©rjr"rN)r r r r rÇr‘r’r1rçrÏrÓrìr{rÂrÅrBr6r:r=rrrrr$r$–s‘†ò2ð×Ññ%óð%ò+ò ò òTð ×*Ñ*€Jà ñ%óð%ðñ+óð+ðñ(óð(ðñ)óó)rr$có^•\rSrSrSr\rSSjr\\ R"5S55r Sr g)riÙaIThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 có ^•URU5umn[T5UlURU5uUlUl[ UR5nU[ UR5-U:wa;U(a[SU-5e[U[ UR5-5UlUR URS- :XaURUl gUR UR:Xa U4SjUl gg)a)Instantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.2.0/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. ú%s has host bits setr:có.>•[[T545$r¿)r;r©r7s€rÚÚ&IPv4Network.__init__..󸀤¤{°4Ó'8Ð&:Ô!;rN) r¼rrlrŸr"rjr°rrRrr©rrr!rórËr7s @rrÇÚIPv4Network.__init__èsÞø€ðF×,Ñ,¨WÓ5‰ ˆˆdä*¨4Ó0ˆÔØ(,×(:Ñ(:¸4Ó(@Ñ%ˆŒ �d”oÜ�T×)Ñ)Ó*ˆØ ”C˜Ÿ ™ Ó%Ñ %¨Ó /ÞÜ Ð!7¸$Ñ!>Ó?Ð?ä'2°6Ü36°t·|±|Ó3Dñ4Eó(F�Ô$ð �?‰?˜t×2Ñ2°QÑ6Ó 7ØŸ™ˆD�JØ �_‰_ ×!4Ñ!4Ó 5Ü;ˆD�Jð6rcóª•UR[S5;=(a UR[S5;(+=(a UR(+$)z™Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. ú 100.64.0.0/10)rlrrbr„r~s rr‡ÚIPv4Network.is_globalsJ€ð×)Ñ)¬[¸Ó-IÑI÷KØ×*Ñ*¬k¸/Ó.JÑJôL÷$à—O‘OÔ#ð %r©rjrr"rlN©T) r r r r rrrrÇrÅr‘rîr‡rrrrrrÙs9†ñ ð!€Nô2<ðhØ×ÒÓñ %óóó %rrcó\•\rSrSr\"S5r\"S5r\"S5r\"S5r\"S5\"S5\"S5\"S5\"S5\"S 5\"S 5\"S 5\"S 5\"S 5\"S5\"S5\"S5\"S5/r \"S5\"S5/r \"S5r \ "S5r Srg)Ú_IPv4Constantsi+z169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4r%z 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/24z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z 192.0.0.9/32z 192.0.0.10/32z0.0.0.0rN)r r r r rréræràrÝr�rƒrÏrrãrrrrr*r*+sà†Ù$Ð%5Ó6Ðá# MÓ2Ðá$ ]Ó3Ðá! /Ó2€Oñ �KÓ Ù�LÓ!Ù�MÓ"ÙÐ$Ó%Ù�OÓ$Ù�NÓ#ÙÐ$Ó%Ù�NÓ#ÙÐ$Ó%Ù�OÓ$ÙÐ%Ó&ÙÐ$Ó%Ù�MÓ"ÙÐ(Ó)ð Ðñ$ �NÓ#Ù�OÓ$ð$Ð ñ $ MÓ2Ðá& yÓ1Órr*cóÜ•\rSrSrSrSrSrS\-S- rSr \ "S5r \r 0r \S 5r\S 5r\S 5r\S 5r\SSj5rSrSr\S5r\S5r\S5rSrg )Ú_BaseV6iUzmBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. rrMr3r:rŸÚ0123456789ABCDEFabcdefcó8•XR;a}[U[5(a-UnSUs=::aUR::dO UR U5 OUR U5n[ URU55nX24URU'URU$r›)rœrNr°rRr«r²rrœr�s rrŸÚ_BaseV6._make_netmaskis�€ð ×(Ñ(Ó (ܘ#œs×#Ñ#Ø� ؘYÕ<¨#×*<Ñ*<Õ<Ø×/Ñ/° Ô:øà×:Ñ:¸3Ó?� Ü! #×"9Ñ"9¸)Ó"DÓEˆGØ&-Ð&8ˆC× Ñ ˜sÑ #Ø×!Ñ! #Ñ&Ð&rcó<•U(d [S5e[U5S:”a<Un[U5S:”aUSSS[U5S- SUSS3n[S U<35eURS -nURS US 9nS n[U5U:aSXQ4-n[U5eSUS;aU[ UR 55R nURSUS- S--5 URSUS--5 [U5U:”aSUS - U4-n[U5eSn [S [U5S - 5H#n XJ(aMU bSU-n[U5eU n M% U b“U n [U5U - S - n US(dU S -n U (aSn[Xa-5eUS(dU S -n U (aSn[Xa-5eURX¼-- n U S :aSn[X`RS - U4-5eOu[U5UR:waSn[X`RU4-5eUS(dSn[Xa-5eUS(dSn[Xa-5e[U5n Sn Sn Sn[U 5Hn US-nXàRXJ5-nM USU --n[U *S5Hn US-nXàRXJ5-nM U$![an[U<SU<35SeSnAff=f![an[U<SU<35SeSnAff=f)zÁTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. r¢é-édNrßéZz chars elided)iÓÿÿÿz"At most 45 characters expected in r:Ú:)Úmaxsplitr¬z At least %d parts expected in %rr£rhr¤ú%xr/éÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) rr6Ú _HEXTET_COUNTr5rr\r=r_rÚ _parse_hextetr)ršr¶ÚshortenÚ _max_partsÚpartsÚ _min_partsr�Úipv4_intr©Ú skip_indexÚiÚparts_hiÚparts_loÚ parts_skippedr¡s rrµÚ_BaseV6._ip_int_from_string}s†€öÜ#Ð$=Ó>Ð >Ü ˆv‹;˜Ó ؈GÜ�7‹|˜cÓ!Ø# C R˜[˜M¨¬3¨v«;°r©>Ð*:¸.ÈÐPSÐPTÈÈÐW�Ü#Ð&HØ'.¡kð%3ó4ð 4ð ×&Ñ&¨Ñ*ˆ Ø— ‘ ˜S¨:� Ð6ˆðˆ Ü ˆu‹:˜ Ó "Ø4¸ Ð7KÑKˆCÜ# CÓ(Ð (ð �%˜‘)Ó ð NÜ& u§y¡y£{Ó3×7Ñ7�ð �L‰L˜ (¨b¡.°FÑ!:Ñ;Ô <Ø �L‰L˜ ¨FÑ!2Ñ3Ô 4ô ˆu‹:˜ Ó "Ø5¸ÀA¹ÀvÐ8NÑNˆCÜ# CÓ(Ð (ðˆ Ü�qœ#˜e›* q™.Ö)ˆAØ—8‘8ØÑ)à<¸vÑE�CÜ+¨CÓ0Ð0Ø’ ñ *ð Ñ !à!ˆHܘ5“z JÑ.°Ñ2ˆHؘ—8ؘA‘ �ÞØL�CÜ+¨C©LÓ9Ð9ؘ—9ؘA‘ �ÞØM�CÜ+¨C©LÓ9Ð9Ø×-Ñ-°Ñ1DÑEˆMؘqÓ ØG�Ü'¨×/@Ñ/@ÀÑ/BÀFÐ.KÑ(KÓLÐLð!ô�5‹z˜S×.Ñ.Ó.ØD�Ü'¨×/@Ñ/@À&Ð.IÑ(IÓJÐJؘ—8ØH�Ü'¨© Ó5Ð5ؘ—9ØI�Ü'¨© Ó5Ð5ܘ5“zˆH؈H؈Mð JàˆFܘ8–_�ؘ2‘ �Ø×+Ñ+¨E©HÓ5Ñ5’ñ%ð �r˜MÑ)Ñ )ˆFܘH˜9 aÖ(�ؘ2‘ �Ø×+Ñ+¨E©HÓ5Ñ5’ñ)ðˆMøôM%ó NÜ'³cº6Ð(BÓCÈÐMûð NûôNó JÜ#³#²vÐ$>Ó?ÀTÐ Iûð Jús1Â)#KÉ.A%K9Ë K6ËK1Ë1K6Ë9 LÌLÌLcó²•URRU5(d[SU-5e[U5S:”aSn[X!-5e[ US5$)zæConvert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rr(z$At most 4 characters permitted in %rr/)Ú _HEX_DIGITSÚ issupersetrr6r°)ršÚ hextet_strr�s rr9Ú_BaseV6._parse_hextetîsX€ð �‰×)Ñ)¨*×5Ñ5ÜÐ>ÀÑKÓLÐ Lô ˆz‹?˜QÓ Ø8ˆCܘSÑ-Ó.Ð .ä�:˜rÓ"Ð"rcóè•SnSnSnSn[U5H)upgUS:XaUS- nUS:XaUnXS:”aUnUnM#M%SnSnM+ US:”a+UU-nU[U5:XaUS/- nS/XU&US:XaS/U-nU$)a”Compresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. rhrrør:Ú)Ú enumerater6) ršÚhextetsÚbest_doublecolon_startÚbest_doublecolon_lenÚdoublecolon_startÚdoublecolon_lenÚindexÚhextetÚbest_doublecolon_ends rÚ_compress_hextetsÚ_BaseV6._compress_hextetssÅ€ð""$ÐØ ÐØÐØˆÜ& wÖ/‰MˆEؘ‹}Ø 1Ñ$�Ø$¨Ó*à(-Ð%Ø"Ó9à+:Ð(Ø->Ò*ñ:ð #$�Ø$&Ò!ñ0ð  !Ó #Ø$:Ø$8ñ%9Ð ð$¤s¨7£|Ó3ؘB˜4‘�ØDFÀ4ˆGÐ+?Ð @à%¨Ó*ؘ$ ™.�àˆrNc ó•Uc[UR5nXR:”a [S5eSU-n[ SSS5Vs/sHnS[X#US-S5-PM nnUR U5nSR U5$s snf) zôTurns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. zIPv6 address is too largeú%032xrrr(r6r/r4)r°r=rSrrrUr³)ršr¡Úhex_strr÷rMs rræÚ_BaseV6._string_from_ip_int8s‹€ð ‰>ܘŸ™“\ˆFà —M‘MÓ !ÜÐ8Ó9Ð 9à˜FÑ"ˆÜ;@ÀÀBȼ?ÓKº?°a�4œ#˜g¨¨!©˜n¨bÓ1Ô1¹?ˆÐKà×'Ñ'¨Ó0ˆØ�x‰x˜Ó Ð ùòLsÁB cóÔ•[U[5(a[UR5nO6[U[5(a[UR 5nO [U5nUR U5nSU-n[SSS5Vs/sH oCXDS-PM nn[U[[45(a SSRU5UR4-$SRU5$s snf)zUExpand a shortened IPv6 address. Returns: A string, the expanded IPv6 address. rXrrr(rr4) rNr r4rlr%rBrµrrtr³rj)rr¶r¡rYr÷r<s rr}Ú$_BaseV6._explode_shorthand_ip_stringRsÁ€ô �dœK× (Ñ (ܘ×-Ñ-Ó.‰FÜ ˜œm× ,Ñ ,ܘŸ™“\‰F䘓YˆFà×)Ñ)¨&Ó1ˆØ˜FÑ"ˆÜ).¨q°"°a¬Ó9ª A˜˜Q™3“©ˆÐ9Ü �dœ\¬=Ð9× :Ñ :ؘcŸh™h u›o¨t¯©Ð?Ñ?Ð ?Ø�x‰x˜‹Ðùò:sÂC%cón•URSSS2RSS5nSRU5S-$)zqReturn the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. Nrhr4rKr£ú .ip6.arpa)r€Úreplacer³)rÚ reverse_charss rr‡Ú_BaseV6._reverse_pointergs7€ð Ÿ ™ ¡d¨ dÑ+×3Ñ3°C¸Ó<ˆ Ø�x‰x˜ Ó&¨Ñ4Ð4rcó~•URS5upnU(dSnX4$U(aSU;a[SU-5eX4$)z­Helper function to parse IPv6 string address with scope id. See RFC 4007 for details. Args: ip_str: A string, the IPv6 address. Returns: (addr, scope_id) tuple. Ú%NzInvalid IPv6 address: "%r")Ú partitionr)r¶r7ÚsepÚscope_ids rÚ_split_scope_idÚ_BaseV6._split_scope_idpsO€ð%×.Ñ.¨sÓ3ш�8ÞØˆHðˆ~Ðö˜S H›_Ü#Ð$@À6Ñ$IÓJÐ J؈~Ðrcó•UR$r¿r¹r~s rrºÚ_BaseV6.max_prefixlen„r¼rcó•UR$r¿rïr~s rrQÚ_BaseV6.versionˆr¿rr¿)r r r r rrÄriÚ IPV6LENGTHrSr8Ú frozensetrFrRrœrÆrŸrµr9rUrær}r‡r“rgrÅrºrQrrrrr,r,Usë†ñð€IØ€HØ�J‘ !Ñ#€IØ€MÙÐ4Ó5€KØ€Nð€Nàñ'óð'ð&ñnJóðnJð`ñ#óð#ð2ñ-óð-ð^ó!óð!ò2ò*5ðñóðð&ñ#óð#ðñóórr,cód^•\rSrSrSrSrSrU4SjrU4SjrSr U4Sjr S r U4S jr S r \S 5r\S 5r\S5r\S5r\S5r\S5r\\R,"5S55r\S5r\S5r\S5r\S5r\S5r\S5rSrU=r$)ri�z/Represent and manipulate single IPv6 Addresses.)r=Ú _scope_idrÂcóœ•[U[5(aURU5 XlSUlg[U[ 5(a5UR US5 [RUS5UlSUlg[U5nSU;a[SU<35eURU5uo lURU5Ulg)a¬Instantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nr/r r2rÄ) rNr°r’r=rprºr—r¥r4rrgrµrÅs rrÇÚIPv6Address.__init__“sµ€ô$ �gœs× #Ñ #Ø × #Ñ # GÔ ,ØŒHØ!ˆDŒNØ ô �gœu× %Ñ %Ø × &Ñ & w°Ô 3Ü—~‘~ g¨uÓ5ˆDŒHØ!ˆDŒNØ ô�w“<ˆØ �(‹?Ü#Ð&8¸¹ Ð$DÓEÐ EØ#'×#7Ñ#7¸Ó#AÑ ˆ”.à×+Ñ+¨HÓ5ˆ�rcór>•URnUc[TU] 5$Sn[TU] 5nUSUU<3$)Né)Ú ipv4_mappedrþr})rruÚ prefix_lenÚraw_exploded_strrÁs €rr}Ú(IPv6Address._explode_shorthand_ip_string»sLø€Ø×&Ñ&ˆ Ø Ñ Ü‘7Ñ7Ó9Ð 9؈ Ü ™7Ñ?ÓAÐØ" ; JÐ/Ð0°±Ð@Ð@rcóÞ>•URnUc[TU] 5$Sn[TU] 5SUnURnUUS3SSS2R SS5nSR U5S-$)NrtÚ008xrhr4rKr£r^)rurþr‡r}r=r_r³)rrurvrwr>r`rÁs €rr‡ÚIPv6Address._reverse_pointerÃs�ø€Ø×&Ñ&ˆ Ø Ñ Ü‘7Ñ+Ó-Ð -؈ Ü ™7Ñ?ÓAÀ+À:ÐNÐà—?‘?ˆØ+Ð,¨X°d¨OÐ<¹T¸r¸TÑB×JÑJÈ3ÐPRÓSˆ Ø�x‰x˜ Ó&¨Ñ4Ð4rcó®•URnUc[S[U5-5eURS- nUR U5<S[U5<3$)a�Return convenient text representation of IPv4-mapped IPv6 address See RFC 4291 2.5.5.2, 2.2 p.3 for details. Returns: A string, 'x:x:x:x:x:x:d.d.d.d', where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation) as defined in RFC 4291 2.2 p.3. z0Can not apply to non-IPv4-mapped IPv6 address %srr4)rurr4r=ræ)rruÚhigh_order_bitss rÚ_ipv4_mapped_ipv6_to_strÚ$IPv6Address._ipv4_mapped_ipv6_to_strÎsU€ð×&Ñ&ˆ Ø Ñ Ü#Ð$VÔY\Ð]aÓYbÑ$bÓcÐ cØŸ(™( b™.ˆØ×2Ñ2°?ÖCÄSÈÕEUÐVÐVrcóª>•URnUc[TU] 5nOUR5nUR(aUS-UR-$U$)Nrc)rurþrçr~rp)rrur¶rÁs €rrçÚIPv6Address.__str__àsLø€Ø×&Ñ&ˆ Ø Ñ Ü‘W‘_Ó&‰Fà×2Ñ2Ó4ˆFØ04··ˆv˜‰|˜dŸn™nÑ,ÐJÀFÐJrcóD•[URUR45$r¿)rêr=rpr~s rrìÚIPv6Address.__hash__ès€Ü�T—X‘X˜tŸ~™~Ð.Ó/Ð/rcó„>•[TU]U5nU[La[$U(dgUR[ USS5:H$)NFrp)rþrÏrwrpÚgetattr)rrÎrÿrÁs €rrÏÚIPv6Address.__eq__ës=ø€Ü™™ uÓ-ˆ Ø œNÒ *Ü!Ð !ÞØØ�~‰~¤¨° ¸TÓ!BÑBÐBrcó2•UR[U544$r¿rÀr~s rrÂÚIPv6Address.__reduce__ós€Ø—‘¤ T£  Ð-Ð-rcó•UR$)z¨Identifier of a particular zone of the address's scope. See RFC 4007 for details. Returns: A string identifying the zone of the address if specified, else None. )rpr~s rrfÚIPv6Address.scope_idös€ð�~‰~Ðrcó,•[UR5$rÊ)r0r=r~s rrËÚIPv6Address.packedrÍrcóh•URnUb UR$XRR;$r`)rurar€rà©rrus rraÚIPv6Address.is_multicasts4€ð×&Ñ&ˆ Ø Ñ "Ø×+Ñ+Ð +Ø—‘×9Ñ9Ñ9Ð9rcóŒ^•TRnUb UR$[U4SjTRR55$)rnc3ó.># •UH nTU;v• M g7fr¿r)rxr÷rs €rrzÚ*IPv6Address.is_reserved..!søé€ÐIÒ&H �4˜1–9Ò&Hùr×)rurorr€Ú_reserved_networksrŽs` rroÚIPv6Address.is_reserveds=ø€ð×&Ñ&ˆ Ø Ñ "Ø×*Ñ*Ð *ÜÔI d§o¡o×&HÒ&HÓIÓIÐIrcóh•URnUb UR$XRR;$rs)rurtr€rérŽs rrtÚIPv6Address.is_link_local#s4€ð×&Ñ&ˆ Ø Ñ "Ø×,Ñ,Ð ,Ø—‘×9Ñ9Ñ9Ð9rcó2•XRR;$©a0Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )r€Ú_sitelocal_networkr~s rÚ is_site_localÚIPv6Address.is_site_local0s€ð—‘×9Ñ9Ñ9Ð9rcóì^•TRnUb UR$[U4SjTRR55=(a) [ U4SjTRR 55$)rÒc3ó.># •UH nTU;v• M g7fr¿rrÔs €rrzÚ)IPv6Address.is_private..SrÖr×c3ó.># •UH nTU;v• M g7fr¿rrÔs €rrzržTrÙr×)rur„rr€r�r‚rƒrŽs` rr„ÚIPv6Address.is_private>s]ø€ð"×&Ñ&ˆ Ø Ñ "Ø×)Ñ)Ð )ä ÔI t§¡×'HÒ'HÓIÓ I÷ ]ÜÔ\¨t¯©×/[Ò/[Ó\Ó\ð rcóZ•URnUb UR$UR(+$rÜ)rur‡r„rŽs rr‡ÚIPv6Address.is_globalWs.€ð×&Ñ&ˆ Ø Ñ "Ø×(Ñ(Ð (Ø—?‘?Ô"Ð"rcóV•URnUb UR$URS:H$)rŠr)rur‹r=rŽs rr‹ÚIPv6Address.is_unspecifiedks/€ð×&Ñ&ˆ Ø Ñ "Ø×-Ñ-Ð -Ø�x‰x˜1‰}ÐrcóV•URnUb UR$URS:H$)rŽr:)rur�r=rŽs rr�ÚIPv6Address.is_loopbackys/€ð×&Ñ&ˆ Ø Ñ "Ø×*Ñ*Ð *Ø�x‰x˜1‰}ÐrcóZ•URS- S:wag[URS-5$)z–Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. rr7Nìÿÿ©r=rr~s rruÚIPv6Address.ipv4_mapped‡s+€ð �H‰H˜‰N˜vÓ %ØÜ˜4Ÿ8™8 jÑ0Ó1Ð1rcó’•URS- S:wag[URS- S-5[UR)S-54$)z³Tuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@r¨r©r~s rÚteredoÚIPv6Address.teredo”sI€ð �H‰H˜‰N˜zÓ )ØÜ˜TŸX™X¨™^¨zÑ9Ó:ܘTŸX™X˜I¨ Ñ2Ó3ð5ð 5rcó`•URS- S:wag[URS- S-5$)z®Return the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPr¨r©r~s rÚ sixtofourÚIPv6Address.sixtofour£s/€ð �H‰H˜‰O Ó &ØÜ˜DŸH™H¨™N¨jÑ8Ó9Ð9r)r=rp) r r r r rrÄrÇr}r‡r~rçrìrÏrÂrÅrfrËrarortršr‘rîr„r‡r‹r�rur®r³rrr s@rrr�sOø†á9à3€Iò&6õPAõ 5òWõ$Kò0õCò.ðñ óð ðñ*óð*ðñ :óð :ðñ Jóð Jðñ :óð :ðñ :óð :ðØ×ÒÓñ óóð ð.ñ#óð#ð&ñ óð ðñ óð ðñ 2óð 2ðñ 5óð 5ðñ :óö :rrcóâ^•\rSrSrSr\R S5rU4SjrSr Sr Sr \ Rr \S5r\S 5r\S 5r\S 5r\S 5r\U4S j5rSrU=r$)r%i±cóà•URU5up#[RX5 [X#4SS9UlURR UlURR Ulgrñ)r¼rrÇr rr"rjròs rrÇÚIPv6Interface.__init__³rõrcó.•URR$r¿r÷r~s rr1ÚIPv6Interface.hostmask»rùrcó>>•S[TU]5UR4-$r)rþrçrj©rrÁs €rrçÚIPv6Interface.__str__¿s%ø€Øœ%™'™/Ó+ØŸ/™/ð+ñ+ð +rcó¤•[RX5nU[LdU(dU$URUR:H$![a gf=fr))rrÏrwrrkrþs rrÏÚIPv6Interface.__eq__Ãrrcóè•[RX5nU[LaU$URUR:=(d" URUR:H=(a U$![a gf=fr))rrÓrwrrkrs rrÓÚIPv6Interface.__lt__Ïsj€Ü"×)Ñ)¨$Ó6ˆ Ø œ>Ò )ØÐ ð Ø—L‘L 5§=¡=Ñ0÷CØ—L‘L E§M¡MÑ1×B°lð Døäó ñð ús¢AA$Á$ A1Á0A1có€•[URUR[URR 545$r¿rr~s rrìÚIPv6Interface.__hash__Ûr rcó,•[UR5$r¿)rr=r~s rrBÚIPv6Interface.ipàr rcóZ•URUR5<SUR<3$r9rûr~s rr6ÚIPv6Interface.with_prefixlenärrcóZ•URUR5<SUR<3$r9rr~s rr:ÚIPv6Interface.with_netmaskérrcóZ•URUR5<SUR<3$r9rr~s rr=ÚIPv6Interface.with_hostmaskîrrcóZ•URS:H=(a URR$)Nr)r=rr‹r~s rr‹ÚIPv6Interface.is_unspecifiedós€à�x‰x˜1‰}×< §¡×!<Ñ!<Е[TU]=(a URR$r¿)rþr�rr»s €rr�ÚIPv6Interface.is_loopback÷sø€ä‰wÑ"×? t§|¡|×'?Ñ'?Ð?rr)r r r r rÇr‘r’r1rçrÏrÓrìr{rÂrÅrBr6r:r=r‹r�rrr s@rr%r%±s¼ø†ò2ð×Ññ%óð%õ+ò ò òTð ×*Ñ*€Jà ñ%óð%ðñ+óð+ðñ(óð(ðñ)óð)ðñ=óð=ðô@óö@rr%có<•\rSrSrSr\rSSjrSr\ S5r Sr g) r iüaZThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 có ^•URU5umn[T5UlURU5uUlUl[ UR5nU[ UR5-U:wa;U(a[SU-5e[U[ UR5-5UlUR URS- :XaURUl gUR UR:Xa U4SjUl gg)aInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. rr:có.>•[[T545$r¿)r;rrs€rrÚ&IPv6Network.__init__..: r!rN) r¼rrlrŸr"rjr°rrRrrr"s @rrÇÚIPv6Network.__init__ sÝø€ð>×,Ñ,¨WÓ5‰ ˆˆdä*¨4Ó0ˆÔØ(,×(:Ñ(:¸4Ó(@Ñ%ˆŒ �d”oÜ�T×)Ñ)Ó*ˆØ ”C˜Ÿ ™ Ó%Ñ %¨Ó /ÞÜ Ð!7¸$Ñ!>Ó?Ð?ä'2°6Ü36°t·|±|Ó3Dñ4Eó(F�Ô$ð �?‰?˜t×2Ñ2°QÑ6Ó 7ØŸ™ˆD�JØ �_‰_ × 3Ñ 3Ó 3Ü;ˆD�Jð4rc#ó¸# •[UR5n[UR5n[US-US-5HnUR U5v• M g7f)z†Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r:Nrrs rrÚIPv6Network.hosts< sQé€ô�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ü�w ‘{ I°¡MÖ2ˆAØ×%Ñ% aÓ(Ô (ò3ùs‚AAcóh•URR=(a URR$r˜)rlršrbr~s rršÚIPv6Network.is_site_localH s,€ð×$Ñ$×2Ñ2÷5Ø×&Ñ&×4Ñ4ð 6rr'Nr() r r r r rrrrÇrrÅršrrrrr r üs-†ñ ð!€Nô.<ò` )ðñ 6óó 6rr có•\rSrSr\"S5r\"S5r\"S5\"S5\"S5\"S5\"S5\"S 5\"S 5\"S 5\"S 5\"S 5\"S5/ r\"S5\"S5\"S5\"S5\"S5\"S5/r\"S5\"S5\"S5\"S5\"S5\"S5\"S5\"S5\"S5\"S5\"S5\"S5\"S 5\"S!5\"S"5/r \"S#5r S$r g%)&Ú_IPv6ConstantsiX z fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z64:ff9b:1::/48z100::/64z 2001::/23z 2001:db8::/32z 2002::/16z 3fff::/20zfc00::/7z 2001:1::1/128z 2001:1::2/128z 2001:3::/32z2001:4:112::/48z 2001:20::/28z 2001:30::/28z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10rN) r r r r r réràr�rƒr“r™rrrrrÙrÙX s>†á$ [Ó1Ðá$ ZÓ0Ðñ �IÓÙ�HÓÙ�OÓ$ÙÐ$Ó%Ù�JÓÙ�KÓ Ù�OÓ$á�KÓ á�KÓ Ù�JÓÙ�KÓ ð Ðñ" �OÓ$Ù�OÓ$Ù�MÓ"ÙÐ%Ó&Ù�NÓ#Ù�NÓ#ð $Ð ñ �FÓ™[¨Ó3Ù�IÓ¡ ¨IÓ 6Ù�IÓ¡ ¨JÓ 7Ù�JÓ¡¨ZÓ!8Ù�JÓ¡¨ZÓ!8Ù�JÓ¡¨ZÓ!8Ù�JÓ¡¨ZÓ!8Ù�JÓð Ðñ% [Ó1ÓrrÙr()%rÚ __version__r‘rÀrmrrrrr"r&r,r0r8rCrIrYrfrrryr{rúÚtotal_orderingrOrtr•r€r—rr$rr*r,rr%r rÙrrrÚrÜs¨ðñð€ óà € Ø € ô0˜ ô0ô0˜ ô0òSô:Sò:UòDCò( Cò òò( :ò 4òn.òb36òl÷2o,ño,ðd€à ×ÑôhN�>óhNóðhNðV ×ÑôH4�>óH4óðH4÷Vñð )€ Ô÷JñJôZS-�'˜<ôS-ôl@)�Kô@)ôFO%�'˜<ôO%÷d#2ñ#2ðL(€ ÔØ'€ Ô÷uñuôp a:�'˜<ôa:ôH H@�KôH@ôVY6�'˜<ôY6÷x,2ñ,2ð^(€ ÔØ'€ Õr