grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026+ —4Yëx ÈãóL€RtRt^RIt^ t^€t!RR]4t!RR]4tRtR/Rlt R t R t R t R t R tRtRtRtRtRt!RR4tRs]P,!RR]44t]P,!RR]44t!RR4t]]n!RR4t!RR]]4t!RR ]4t!R!R"]]4t!R#R$4t]]n]]n!R%R&4t !R'R(] ]4t!!R)R*]!4t"!R+R,] ]4t#!R-R.4t$]$]!n]$]#nR#)0z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0Ncó€]tRt^tRtRtR#)ÚAddressValueErrorz%A Value Error related to the address.©N©Ú__name__Ú __module__Ú __qualname__Ú__firstlineno__Ú__doc__Ú__static_attributes__róÚ0/opt/alt/python314/lib64/python3.14/ipaddress.pyrró†Ý/r rcó€]tRt^tRtRtR#)ÚNetmaskValueErrorz%A Value Error related to the netmask.rNrrr r rrrr rcó¬€\V4# \\3dMi;i\T4# \\3dMi;i\ T: R24h)a†Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z. does not appear to be an IPv4 or IPv6 address)Ú IPv4AddressrrÚ IPv6AddressÚ ValueError©Úaddresss&r Ú ip_addressrsg€ð  ܘ7Ó#Ð#øÜ Ô0Ð 1ô Ù ð úð ܘ7Ó#Ð#øÜ Ô0Ð 1ô Ù ð úô ˜‘{Ð"PÐQÓ RÐRó‚ �! !¥ 0°AÁAcó¬€\W4# \\3dMi;i\Y4# \\3dMi;i\ T: R24h)a¨Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z. does not appear to be an IPv4 or IPv6 network)Ú IPv4NetworkrrÚ IPv6Networkr)rÚstricts&&r Ú ip_networkr9sg€ð  ܘ7Ó+Ð+øÜ Ô0Ð 1ô Ù ð úð ܘ7Ó+Ð+øÜ Ô0Ð 1ô Ù ð úô ˜‘{Ð"PÐQÓ RÐRrcó¬€\V4# \\3dMi;i\T4# \\3dMi;i\ T: R24h)a/Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z0 does not appear to be an IPv4 or IPv6 interface)Ú IPv4InterfacerrÚ IPv6Interfacerrs&r Ú ip_interfacer!Vsg€ð* ܘWÓ%Ð%øÜ Ô0Ð 1ô Ù ð úð ܘWÓ%Ð%øÜ Ô0Ð 1ô Ù ð úô ˜‘{Ð"RÐSÓ TÐTrcóZ€VP^4# \d \R4hi;i)a@Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. z&Address negative or too large for IPv4©Úto_bytesÚ OverflowErrorrrs&r Úv4_int_to_packedr&xs6€ðCØ×Ñ Ó"Ð"øÜ ôCÜÐAÓBÐBðCúó‚“*cóZ€VP^4# \d \R4hi;i)záRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. z&Address negative or too large for IPv6r#rs&r Úv6_int_to_packedr)Œs6€ðCØ×Ñ Ó#Ð#øÜ ôCÜÐAÓBÐBðCúr'cóx€\V4PR4p\V4^8”d\RV: 24hV#)zAHelper to split the netmask and raise AddressValueError if neededÚ/zOnly one '/' permitted in )ÚstrÚsplitÚlenr)rÚaddrs& r Ú_split_optional_netmaskr0œs9€ä ˆw‹<× Ñ ˜cÓ "€DÜ ˆ4ƒy�1„}ÜÐ"<¸W¹KÐ HÓIÐIØ €Kr c#ó®"€\V4p\V4;r#VF.pVPVP^,8wdW#3x€TpTpK0 W#3x€R#5i)z»Find a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. N)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚips& r Ú_find_address_ranger:¤sVé€ô ˆi‹€Bܘ“8ЀEÛˆØ �6‰6�T—X‘X •\Ô !Ø�+Ò ØˆEØŠñ ð ˆ+Ôùs‚AAcód€V^8XdV#\W(V^, ,P44#)zÍCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. )ÚminÚ bit_length)ÚnumberÚbitss&&r Ú_count_righthand_zero_bitsr@¸s/€ð�„{؈ Ü ˆt�g ¨¥Õ*×6Ñ6Ó8Ó 9Ð9r c#ó²"€\V\4'd\V\4'g \R4hVPVP8wd\V: RV: R24hW8”d \ R4hVP^8Xd\ pM#VP^8Xd\ pM \ R4hVPpVPpVPpWE8:dx\\WC4WT, ^,P4^, 4pV!WCV, 34pVx€V^V,, pV^, VP8XgK{R#R#5i)aXSummarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksú and ú are not of the same versionz*last IP address must be greater than firstzunknown IP versionN) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ max_prefixlenr4r<r@r=Ú _ALL_ONES)r7r8r9Úip_bitsÚ first_intÚlast_intÚnbitsÚnets&& r Úsummarize_address_rangerOÈsé€ô4˜œ|× ,Ò ,Ü ˜œl× +Ò +ÜÐKÓLÐLØ ‡}�}˜Ÿ ™ Ô$ÜÛ£ð&ó'ð 'à „|ÜÐEÓFÐFà ‡}�}˜ÔÜ ‰Ø �‰˜!Ô Ü ‰äÐ-Ó.Ð.à×!Ñ!€GØ— ‘ €IØ�x‰x€HØ Ô ÜÔ.¨yÓBØÕ)¨AÕ-×9Ñ9Ó;¸aÕ?óAˆá�) u�_Ð-Ó.ˆØŠ Ø�Q˜%•ZÕˆ Ø �q�=˜BŸL™LÖ (Ù ñ ùs ‚E EÅEc#óz"€\V4p/pV'dYVP4pVP4pVPV4pVfW2V&KCWS8wgKKW$VP V4K`Rp\ VP 44F*pVeVPVP8¼dK$Vx€TpK, R#5i)a9Loops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r5Úto_mergeÚsubnetsrNrSÚexistingr8s& r Ú_collapse_addresses_internalr\ÿs¥é€ô2�I‹€HØ€Gß Ø�l‰l‹nˆØ—<‘<“>ˆØ—;‘;˜xÓ(ˆØ Ò Ø #�HÓ Ø Ž_àÐ!Ø �O‰O˜HÖ %à €DÜ�g—n‘nÓ&Ö'ˆØ Ò ð×%Ñ%¨×)>Ñ)>Ô>ÙØŠ ØŠó(ùs‚B;˜>B;ÁA B;có´€.p.p.pVEFCp\V\4'dXV'd=VR,PVP8wd\V: RVR,: R24hVP V4KqVP VP 8XdcV'd=VR,PVP8wd\V: RVR,: R24hVP VP4KîV'd=VR,PVP8wd\V: RVR,: R24hVP V4EKF \\V44pV'd/\V4FwrVVP\WV44K! \W,4# \d!TP TP4EKÍi;i)aŸCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterable of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. rBrCéÿÿÿÿ)rDrErGrFrUÚ _prefixlenrHr9ÚAttributeErrorÚnetwork_addressrVÚsetr:ÚextendrOr\)r5ÚaddrsÚipsÚnetsr9r7r8s& r Úcollapse_addressesrg0ss€ð$ €EØ €CØ €DôˆÜ �bœ,× 'Ò 'ß�s˜2•w—‘¨"¯*©*Ô4ÜÛ!# S¨§W Wð!.ó/ð/à �J‰J�rŽNØ �]‰]˜b×.Ñ.Ô .ß�s˜2•w—‘¨"¯*©*Ô4ÜÛ!# S¨§W Wð!.ó/ð/ð /Ø— ‘ ˜2Ÿ5™5Ö!÷˜˜R�×(Ñ(¨B¯J©JÔ6ÜÛ!# T¨"§X Xð!/ó0ð0à �K‰K˜�Oñ%ô* ”�S“Ó €C÷ Ü.¨sÖ3‰KˆEØ �L‰LÔ0°Ó=Ö >ñ4ô (¨­ Ó 5Ð5øô!"ô /Ø— ‘ ˜2×-Ñ-×.Ð.ð /úsÃF,Æ,&GÇGcó¦€\V\4'dVP4#\V\4'dVP 4#\ #)aReturn a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )rDÚ _BaseNetworkÚ_get_networks_keyrEÚ_get_address_keyÚNotImplemented)Úobjs&r Úget_mixed_type_keyrnfsB€ô$�#”|×$Ò$Ø×$Ñ$Ó&Ð&Ü �Cœ× &Ò &Ø×#Ñ#Ó%Ð%Ü Ðr cóÊa€]tRtRtoRtRt]R4t]R4t]R4t Rt Rt ] R4t ] R 4t] R 4t] R 4t] R 4t] R 4tRtRtVtR#)Ú_IPAddressBaseizThe mother class.c ó"€VP4#)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string©Úselfs&r ÚexplodedÚ_IPAddressBase.exploded…s€ð×0Ñ0Ó2Ð2r c ó€\V4#)z;Return the shorthand version of the IP address as a string.©r,rss&r Ú compressedÚ_IPAddressBase.compressedŠs€ô�4‹yÐr c ó"€VP4#)aThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointerrss&r Úreverse_pointerÚ_IPAddressBase.reverse_pointer�s€ð×$Ñ$Ó&Ð&r cóÆ€V^8d Rp\W!VP3,4hWP8”d+Rp\W!VPVP3,4hR#)éz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d addressN)rrGrIrH)rtrÚmsgs&& r Ú_check_int_addressÚ!_IPAddressBase._check_int_addressšsa€Ø �QŒ;ØAˆCÜ# C°D·L±LÐ*AÕ$AÓBÐ BØ —^‘^Ô #ØFˆCÜ# C°D×4FÑ4FØ+/¯<©<ð+9õ%9ó:ð :ñ $r cóh€\V4pW28wd!Rp\WAVW P3,4hR#)z6%r (len %d != %d) is not permitted as an IPv%d addressN)r.rrG)rtrÚ expected_lenÚ address_lenr�s&&& r Ú_check_packed_addressÚ$_IPAddressBase._check_packed_address£sA€Ü˜'“lˆ Ø Ô &ØJˆCÜ# C°KØ+7¿¹ð+Gõ%GóHð Hñ 'r c óJ€VPVPV, , #)z~Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )rI)ÚclsÚ prefixlens&&r Ú_ip_int_from_prefixÚ"_IPAddressBase._ip_int_from_prefixªs€ð�}‰} § ¡ °Õ :Õ;Ð;r c ó€\VVP4pVPV, pW, p^V,^, pWE8wd9VP^,pVPVR4pRp\W‡,4hV#)zãReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones Úbigz&Netmask pattern %r mixes zeroes & ones)r@rHr$r) rŠÚip_intÚtrailing_zeroesr‹Ú leading_onesÚall_onesÚbyteslenÚdetailsr�s && r Ú_prefix_from_ip_intÚ"_IPAddressBase._prefix_from_ip_int·s~€ô5°VØ58×5FÑ5FóHˆà×%Ñ%¨Õ7ˆ ØÕ0ˆ ؘ•N aÕ'ˆØ Ô #Ø×(Ñ(¨AÕ-ˆHØ—o‘o h°Ó6ˆGØ:ˆCܘS�]Ó+Ð +ØÐr có,€RV,p\V4Rh)z%r is not a valid netmaskN)r)rŠÚ netmask_strr�s&& r Ú_report_invalid_netmaskÚ&_IPAddressBase._report_invalid_netmaskÐs€à)¨KÕ7ˆÜ Ó$¨$Ð.r c ó4€VP4'dVP4'gVPV4\V4p^Xu;8:dVP 8:gMVPV4V# \dTPT4LLi;i)zÑReturn prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask )ÚisasciiÚisdigitršÚintrrH)rŠÚ prefixlen_strr‹s&& r Ú_prefix_from_prefix_stringÚ)_IPAddressBase._prefix_from_prefix_stringÕs†€ð×%Ñ%×'Ò'¨M×,AÑ,A×,CÒ,CØ × 'Ñ '¨ Ô 6ð 7ܘMÓ*ˆIð�YÖ3 #×"3Ñ"3Ö3Ø × 'Ñ '¨ Ô 6ØÐøô ô 7Ø × 'Ñ '¨ Ö 6ð 7ús¿ A8Á8BÂBc ó@€VPV4pVPX4# \dTPT4L0i;i \dMi;iXTP ,pTPT4# \dTPT4R#i;i)zæTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrršr–rrI)rŠÚip_strr�s&& r Ú_prefix_from_ip_stringÚ%_IPAddressBase._prefix_from_ip_stringîs¢€ð 0Ø×,Ñ,¨VÓ4ˆFð Ø×*Ñ*¨6Ó2Ð 2øô!ô 0Ø × 'Ñ '¨Ö /ð 0ûôô Ù ð úð �#—-‘-Õˆð 0Ø×*Ñ*¨6Ó2Ð 2øÜô 0Ø × 'Ñ '¨× /ð 0ús2‚%”A¥AÁAÁ AÁAÁ,A=Á=BÂBc óä€\V\\34'dWP3#\V\4'g \ V4p\ V4^8”dV#V^,VP3#)z�Helper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. )rDÚbytesrŸrHÚtupler0r.)rŠrs&&r Ú_split_addr_prefixÚ!_IPAddressBase._split_addr_prefixse€ô �g¤¤s˜|× ,Ò ,Ø×-Ñ-Ð-Ð -ä˜'¤5×)Ò)ô.¨gÓ6ˆGô ˆw‹<˜!Ô ØˆNØ�q�z˜3×,Ñ,Ð,Ð,r có2€VP\V433#©N©Ú __class__r,rss&r Ú __reduce__Ú_IPAddressBase.__reduce__(s€Ø�~‰~¤ D£ ˜|Ð+Ð+r rN)rrrr r Ú __slots__Úpropertyruryr}r‚r‡Ú classmethodrŒr–ršr¡r¦r«r±r Ú__classdictcell__©Ú __classdict__s@r rprpsÕø‡€áà€Ià ñ3óð3ðñóððñ'óð'ò:òHðñ <óð <ðñóðð0ñ/óð/ðñóðð0ñ0óð0ðBñ-óð-÷.,ð,r rpcóvaa€]tRtRtoRtRtRtRtRtRt Rt Rt R t R t R tR tV3R ltRtVtV;t#)rEi.ztA generic IP object. This IP class contains the version independent methods which are used by single IP addresses. có€VP#r®©r4rss&r Ú__int__Ú_BaseAddress.__int__9s €Ø�x‰xˆr có¦€VPVP8H;'dVPVP8H# \d \u#i;ir®)r4rGr`rl©rtÚothers&&r Ú__eq__Ú_BaseAddress.__eq__<sK€ð "Ø—H‘H § ¡ Ñ)÷6ð6ØŸ ™ ¨¯ © Ñ5ð 7øäô "Ü!Ò !ð "ús‚<¢<¼AÁAcó€\V\4'g\#VPVP8wd\ V: RV: R24hVP VP 8wdVP VP 8#R#©rBrCF)rDrErlrGrFr4r¿s&&r Ú__lt__Ú_BaseAddress.__lt__Csb€Ü˜%¤×.Ò.Ü!Ð !Ø �<‰<˜5Ÿ=™=Ô (ÜÛ!£5ð*ó+ð +à �8‰8�u—y‘yÔ Ø—8‘8˜eŸi™iÑ'Ð 'Ùr có|€\V\4'g\#VP\V4V,4#r®©rDrŸrlr°r¿s&&r Ú__add__Ú_BaseAddress.__add__Oó-€Ü˜%¤×%Ò%Ü!Ð !Ø�~‰~œc $›i¨%Õ/Ó0Ð0r có|€\V\4'g\#VP\V4V, 4#r®rÈr¿s&&r Ú__sub__Ú_BaseAddress.__sub__TrËr cóP€VPP: R\V4: R2#©Ú(Ú)©r°rr,rss&r Ú__repr__Ú_BaseAddress.__repr__Yó€ØŸ>™>×2Ô2´C¸¶IÐ>Ð>r cóJ€\VPVP44#r®)r,Ú_string_from_ip_intr4rss&r Ú__str__Ú_BaseAddress.__str__\s€Ü�4×+Ñ+¨D¯H©HÓ5Ó6Ð6r cóP€\\\VP444#r®)ÚhashÚhexrŸr4rss&r Ú__hash__Ú_BaseAddress.__hash___s€Ü”Cœ˜DŸH™H› Ó&Ó'Ð'r có€VPV3#r®)rGrss&r rkÚ_BaseAddress._get_address_keybs€Ø— ‘ ˜dÐ#Ð#r có4€VPVP33#r®)r°r4rss&r r±Ú_BaseAddress.__reduce__es€Ø�~‰~ §¡˜{Ð*Ð*r c ó4<€V'dVR,R8Xd\\V4V4#\f^RIpVP R4s\P V4pV'g\ SV`V4#VP4wrEpVR8XdVP^8XdRpMRpVR8XdVPpMVP^,pV'dWw^,^, , pV'd V^, p\\V4V RV V V 24#) a°Returns an IP address as a formatted string. Supported presentation types are: 's': returns the IP address as a string (default) 'b': converts to binary and returns a zero-padded string 'X' or 'x': converts to upper- or lower-case hex and returns a zero-padded string 'n': the same as 'b' for IPv4 and 'x' for IPv6 For binary and hex presentation types, the alternate form specifier '#' and the grouping option '_' are supported. ÚsNz(#?)(_?)([xbnX])ÚnÚbÚxÚ0r^) Úformatr,Ú_address_fmt_reÚreÚcompileÚ fullmatchÚsuperÚ __format__ÚgroupsrGrHrŸ) rtÚfmtrìÚmÚ alternateÚgroupingÚfmt_baseÚpadlenr°s && €r rðÚ_BaseAddress.__format__hsôø€÷�c˜"•g ”nÜœ#˜d›) SÓ)Ð )ô Ò "Û Ø Ÿj™jÐ);Ó<ˆOä × %Ñ % cÓ *ˆßÜ‘7Ñ% cÓ*Ð *à()¯©« Ñ%ˆ ˜Xð �sŒ?Ø�|‰|˜qÔ Ø‘à�à �sŒ?Ø×'Ñ'‰Fà×'Ñ'¨1Õ,ˆFç Ø  •k A•oÕ %ˆFç Ø �a�KˆFä”c˜$“i I ;¨a°¨x¸°zÀ(ÀÐ!LÓMÐMr r)rrrr r r³r¼rÁrÅrÉrÍrÔrÙrÞrkr±rðr r¶Ú __classcell__©r°r¸s@@r rErE.sOù‡€ñð €Iòò"òò1ò 1ò ?ò7ò(ò$ò+÷/Nõ/Nr rEcóºa€]tRtRtoRtRtRtRtRtRt Rt R t R t R t R t]P R 4t]P R4t]R4t]R4t]R4t]R4t]R4t]R4tRtRtRtR&RltR&Rlt]R4t] R4t!Rt"Rt#]R4t$]R 4t%]R!4t&]R"4t']R#4t(]R$4t)R%t*Vt+R#)'riišzqA generic IP network object. This IP class contains the version independent methods which are used by networks. cóP€VPP: R\V4: R2#rÐrÓrss&r rÔÚ_BaseNetwork.__repr__¢rÖr có@€RVPVP3,#©ú%s/%d)rar‹rss&r rÙÚ_BaseNetwork.__str__¥s€Ø˜$×.Ñ.°·±Ð?Õ?Ð?r c# ó¼"€\VP4p\VP4p\V^,V4FpVP V4x€K R#5i)z‡Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. N©rŸrarXÚrangeÚ_address_class©rtÚnetworkÚ broadcastrès& r ÚhostsÚ_BaseNetwork.hosts¨sMé€ô�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ü�w •{ IÖ.ˆAØ×%Ñ% aÓ(Ô (ó/ùs‚AAc#óº"€\VP4p\VP4p\W^,4FpVP V4x€K R#5i©éNrrs& r Ú__iter__Ú_BaseNetwork.__iter__´sIé€Ü�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ü�w¨A¥ Ö.ˆAØ×%Ñ% aÓ(Ô (ó/ùs‚AAcó2€\VP4p\VP4pV^8¼d0W!,V8”d \R4hVP W!,4#V^, pW1,V8d \R4hVP W1,4#)r€zaddress out of range)rŸrarXÚ IndexErrorr)rtrærrs&& r Ú __getitem__Ú_BaseNetwork.__getitem__ºs„€Ü�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ø �Œ6Ø�{˜YÔ&Ü Ð!7Ó8Ð8Ø×&Ñ& w¥{Ó3Ð 3à ��FˆAØ�}˜wÔ&Ü Ð!7Ó8Ð8Ø×&Ñ& y¥}Ó5Ð 5r cój€\V\4'g\#VPVP8wd\ V: RV: R24hVP VP 8wdVP VP 8#VP VP 8wdVP VP 8#R#rÄ)rDrirlrGrFraÚnetmaskr¿s&&r rÅÚ_BaseNetwork.__lt__Çs�€Ü˜%¤×.Ò.Ü!Ð !Ø �<‰<˜5Ÿ=™=Ô (ÜÛ!£5ð*ó+ð +à × Ñ  5×#8Ñ#8Ô 8Ø×'Ñ'¨%×*?Ñ*?Ñ?Ð ?Ø �<‰<˜5Ÿ=™=Ô (Ø—<‘< %§-¡-Ñ/Ð /Ùr có €VPVP8H;'dMVPVP8H;'d,\VP4\VP48H# \d \ u#i;ir®)rGrarŸrr`rlr¿s&&r rÁÚ_BaseNetwork.__eq__Ósu€ð "Ø—L‘L E§M¡MÑ1÷<ð<Ø×(Ñ(¨E×,AÑ,AÑA÷<ð<䘟 ™ Ó%¬¨U¯]©]Ó);Ñ;ð =øôô "Ü!Ò !ð "ús‚A/¢ A/Á+A/Á/BÂBcóh€\\VP4\VP434#r®)rÜrŸrarrss&r rÞÚ_BaseNetwork.__hash__Ûs&€Ü”S˜×-Ñ-Ó.´°D·L±LÓ0AÐBÓCÐCr cóè€VPVP8wdR#\V\4'dR#VPVPP,VP P8H#©F)rGrDrir4rrar¿s&&r Ú __contains__Ú_BaseNetwork.__contains__ÞsQ€à �<‰<˜5Ÿ=™=Ô (Ùä �eœ\× *Ò *Ùð—9‘9˜tŸ|™|×/Ñ/Õ/°4×3GÑ3G×3KÑ3KÑKÐ Kr c óª€VPV9;'g>VPV9;'g'VPV9;'gVPV9#)z*Tell if self is partly contained in other.©rarXr¿s&&r ÚoverlapsÚ_BaseNetwork.overlapsês]€à×#Ñ# uÑ,÷7ð7Ø × "Ñ " eÑ +÷ 6ð 6Ø×%Ñ%¨Ñ-÷5ð5Ø×+Ñ+¨tÑ3ð 7r có~€VP\VP4\VP4,4#r®)rrŸraÚhostmaskrss&r rXÚ_BaseNetwork.broadcast_addressñs3€à×"Ñ"¤3 t×';Ñ';Ó#<Ü#& t§}¡}Ó#5õ$6ó7ð 7r cól€VP\VP4VP, 4#r®)rrŸrrIrss&r r$Ú_BaseNetwork.hostmaskös%€à×"Ñ"¤3 t§|¡|Ó#4°t·~±~Õ#EÓFÐFr có@€RVPVP3,#rÿ)rar_rss&r Úwith_prefixlenÚ_BaseNetwork.with_prefixlenús€à˜$×.Ñ.°·±Ð@Õ@Ð@r có<€VP: RVP: 2#©r+)rarrss&r Ú with_netmaskÚ_BaseNetwork.with_netmaskþs€à×.Ô.°· ³ Ð=Ð=r có<€VP: RVP: 2#r,)rar$rss&r Ú with_hostmaskÚ_BaseNetwork.with_hostmasks€à×.Ô.°· ³ Ð>Ð>r c ón€\VP4\VP4, ^,#)z&Number of hosts in the current subnet.)rŸrXrarss&r Ú num_addressesÚ_BaseNetwork.num_addressess*€ô�4×)Ñ)Ó*¬S°×1EÑ1EÓ-FÕFÈÕJÐJr có>€R\V43,p\V4h)z%%200s has no associated address class)ÚtypeÚNotImplementedError)rtr�s& r rÚ_BaseNetwork._address_class s€ð 6¼¸d»¸ ÕEˆÜ! #Ó&Ð&r có€VP#r®)r_rss&r r‹Ú_BaseNetwork.prefixlens €à�‰Ðr c# óô"€VPVP8Xg\V: RV: R24h\V\4'g\RV,4hVP V4'g\ V: RV: 24hW8XdR#VP VP: RVP: 24pVP4wr#W!8wd|W18wdvVP V4'dVx€VP4wr#K;VP V4'dVx€VP4wr#Kj\RV: RV: R V: 24hW!8XdVx€R#W18XdVx€R#\RV: RV: R V: 24h5i) aêRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. rBrCz%s is not a network objectz not contained in Nr+z Error performing exclusion: s1: z s2: z other: ) rGrFrDriÚ subnet_ofrr°rar‹rZÚAssertionError)rtrÀÚs1Ús2s&& r Úaddress_excludeÚ_BaseNetwork.address_excludesDé€ðH�|‰|˜uŸ}™}Ô,ÜÛ!£5ð*ó+ð +ô˜%¤×.Ò.ÜÐ8¸5Õ@ÓAÐ Aà�‰˜t×$Ò$Ü»ÂÐEÓFÐ FØ Œ=٠𗑨5×+@Ô+@Ø+0¯?«?ð!<ó=ˆð—‘“‰ˆØŒk˜bœkØ�‰˜r×"Ò"ؒ؟™›‘�‘BØ—‘ ×$Ò$ؒ؟™›‘�‘Bõ%ã&(«"ªeð&5ó6ð6ð Œ;ØŒHØ Œ[ØŒHõ!ã"$£bª%ð"1ó2ð 2ùs‚A-E8Á0A:E8Ã+.E8ÄAE8c óJ€VPVP8wd\V: RV: R24hVPVP8dR#VPVP8”d^#VPVP8dR#VPVP8”d^#^#)aåCompare two IP objects. This is only concerned about the comparison of the integer representation of the network addresses. This means that the host bits aren't considered at all in this method. If you want to compare host bits, you can easily enough do a 'HostA._ip < HostB._ip' Args: other: An IP object. Returns: If the IP versions of self and other are the same, returns: -1 if self < other: eg: IPv4Network('192.0.2.0/25') < IPv4Network('192.0.2.128/25') IPv6Network('2001:db8::1000/124') < IPv6Network('2001:db8::2000/124') 0 if self == other eg: IPv4Network('192.0.2.0/24') == IPv4Network('192.0.2.0/24') IPv6Network('2001:db8::1000/124') == IPv6Network('2001:db8::1000/124') 1 if self > other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. rBz are not of the same typer^)rGrFrarr¿s&&r Úcompare_networksÚ_BaseNetwork.compare_networksbs‰€ðB �<‰<˜5Ÿ=™=Ô (ÜÛ!£5ð*ó+ð +ð × Ñ  %×"7Ñ"7Ô 7؈IØ × Ñ  %×"7Ñ"7Ô 7Ùà �<‰<˜%Ÿ-™-Ô '؈IØ �<‰<˜%Ÿ-™-Ô 'ÙÙr c óH€VPVPVP3#)z«Network-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rGrarrss&r rjÚ_BaseNetwork._get_networks_key’s€ð— ‘ ˜d×2Ñ2°D·L±LÐAÐAr Nc# ó`"€VPVP8XdVx€R#Ve@W P8d \R4hV^8wd \R4hW P, pV^8d \R4hVPV,pW0P8”d\RW03,4h\VP4p\VP 4^,p\VP 4^,V, p\WEV4FpVPWs34pVx€K R#5i)a;The subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerú(cannot set prefixlen_diff and new_prefixzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) r_rHrrŸrarXr$rr°) rtÚprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepÚnew_addrÚcurrents &&& r rZÚ_BaseNetwork.subnetsœsé€ð4 �?‰?˜d×0Ñ0Ô 0ØŠJÙ à Ò !ØŸO™OÔ+Ü Ð!<Ó=Ð=Ø Ô"Ü Ð!KÓLÐLØ'¯/©/Õ9ˆNà ˜AÔ ÜÐ=Ó>Ð >ØŸ™¨.Õ8ˆ à ×-Ñ-Ô -ÜØBØ!ðF)õ)ó*ð *ô�D×(Ñ(Ó)ˆÜ�$×(Ñ(Ó)¨AÕ-ˆÜ�D—M‘MÓ" QÕ&¨>Õ9ˆÜ˜e¨$Ö/ˆHØ—n‘n hÐ%>Ó?ˆGØŒMó0ùs‚D,D.c ó®€VP^8XdV#VeAW P8”d \R4hV^8wd \R4hVPV, pVPV, pV^8d\RVPV3,4hVP\ VP 4\ VP 4V,,V34#)aSThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) znew prefix must be shorterrHz;current prefixlen is %d, cannot have a prefixlen_diff of %d)r_rr‹r°rŸrar)rtrIrJrKs&&& r rSÚ_BaseNetwork.supernetÑsÆ€ð* �?‰?˜aÔ ØˆKà Ò !ØŸO™OÔ+Ü Ð!=Ó>Ð>Ø Ô"Ü Ð!KÓLÐLØ!Ÿ_™_¨zÕ9ˆNàŸ™¨Õ7ˆ Ø ˜1Ô ÜØMØ—‘ Ð0õ1ó2ð 2ð�~‰~Ü �×$Ñ$Ó %¬¨T¯\©\Ó):¸nÕ)LÕ MØ ðóð r c ój€VPP;'dVPP#©z›Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )raÚ is_multicastrXrss&r rVÚ_BaseNetwork.is_multicastús1€ð×$Ñ$×1Ñ1÷4ð4Ø×&Ñ&×3Ñ3ð 5r có€VPVP8wd\V RV R24hVPVP8*;'dVPVP8¬# \d\RT RT 24hi;i)rBrCz*Unable to test subnet containment between )rGrFrarXr`)Úarçs&&r Ú _is_subnet_ofÚ_BaseNetwork._is_subnet_ofs™€ð 4à�y‰y˜AŸI™IÔ%Ü 1 # U¨1¨#Ð-IÐ JÓKÐKØ×%Ñ%¨×):Ñ):Ñ:÷?ð?Ø×'Ñ'¨1×+>Ñ+>Ñ>ð @øäô 4Üð'Ø'( c¨¨q¨cð3ó4ð 4ð 4ús‚A A(ÁA(Á(Bc ó$€VPW4#)z1Return True if this network is a subnet of other.©rZr¿s&&r r<Ú_BaseNetwork.subnet_ofs€à×!Ñ! $Ó.Ð.r c ó$€VPW4#)z3Return True if this network is a supernet of other.r]r¿s&&r Ú supernet_ofÚ_BaseNetwork.supernet_ofs€à×!Ñ! %Ó.Ð.r c ój€VPP;'dVPP#)ú•Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )raÚ is_reservedrXrss&r rdÚ_BaseNetwork.is_reservedó1€ð×$Ñ$×0Ñ0÷3ð3Ø×&Ñ&×2Ñ2ð 4r c ój€VPP;'dVPP#©zxTest if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )raÚ is_link_localrXrss&r riÚ_BaseNetwork.is_link_local&s1€ð×$Ñ$×2Ñ2÷5ð5Ø×&Ñ&×4Ñ4ð 6r c óœa€\;QJd3V3RlSPP4F 'gK RM( RM$!V3RlSPP44;'dc\;QJd3V3RlSPP4F 'dK R# R#!V3RlSPP44#)z­Test if this network belongs to a private range. Returns: A boolean, True if the network is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. c3óp<"€TF+pSPV9;'dSPV9x€K- R#5ir®r )Ú.0Ú priv_networkrts& €r Ú Ú*_BaseNetwork.is_private..:sAøé€ðJá'H�|ð×'Ñ'¨<Ñ7÷:ð:Ø×)Ñ)¨\Ñ9ô:ã'Hùóƒ6ž6TFc3óp<"€TF+pSPV9;'dSPV9x€K- R#5ir®r )rmrrts& €r rorp<sDøé€ðRñ$P˜ð×(Ñ(°Ñ7÷:ð:Ø×*Ñ*°'Ñ9ô:ã#Oùrq©ÚanyÚ _constantsÚ_private_networksÚallÚ_private_networks_exceptionsrssfr Ú is_privateÚ_BaseNetwork.is_private1s¬ø€÷‹sôJà'+§¡×'HÒ'HóJ�s�sŠsôJà'+§¡×'HÒ'HóJóJ÷ðçNQËcôRð$(§?¡?×#OÒ#OóRÏcÌcð âNQð àNQôRð$(§?¡?×#OÒ#OóRóOð r c ó$€VP'*#)z·Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )ryrss&r Ú is_globalÚ_BaseNetwork.is_globalBs€ð—?‘?Ô"Ð"r c ój€VPP;'dVPP#©zˆTest if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )raÚis_unspecifiedrXrss&r r€Ú_BaseNetwork.is_unspecifiedMs1€ð×$Ñ$×3Ñ3÷6ð6Ø×&Ñ&×5Ñ5ð 7r c ój€VPP;'dVPP#©z‘Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )raÚ is_loopbackrXrss&r r„Ú_BaseNetwork.is_loopbackYrfr rr ),rrrr r rÔrÙr rrrÅrÁrÞrr!Ú functoolsÚcached_propertyrXr$r´r)r-r0r3rr‹r@rCrjrZrSrVÚ staticmethodrZr<r`rdriryr|r€r„r r¶r·s@r ririšsºø‡€ñò ?ò@ò )ò)ò 6ò ò"òDò Lò7ð×Ññ7óð7ð×ÑñGóðGðñAóðAðñ>óð>ðñ?óð?ðñKóðKðñ'óð'ðñóðòI2òV.ò`Bô3ôj'ðRñ 5óð 5ðñ 4óð 4ò/ò/ðñ 4óð 4ðñ6óð6ðñóðð ñ#óð#ðñ 7óð 7ðñ 4óö 4r ricó€]tRtRt.tRtR#)Ú_BaseConstantsifrN)rrrr rvr rr r rŠrŠfs†àÔr rŠcó a€]tRtRtoRtR t^t^],^, t]t /t Rt ] R4t ] R4t] R4t] R4tRtR tVtR #) Ú_BaseV4inzmBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. có€\V4#r®rxrss&r rrÚ$_BaseV4._explode_shorthand_ip_string�s €Ü�4‹yÐr c óŽ€WP9d‚\V\4'd0Tp^Tu;8:dVP8:gMVP V4MVP V4p\VPV44pW23VPV&VPV,# \ dTPT4pL[i;i©zçMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") ) Ú_netmask_cacherDrŸrHršr¡rr¦rrŒ©rŠÚargr‹rs&& r Ú _make_netmaskÚ_BaseV4._make_netmask„sº€ð ×(Ñ(Ô (ܘ#œs×#Ò#Ø� ؘYÖ;¨#×*;Ñ*;Ö;Ø×/Ñ/° Ô:øð@à #× >Ñ >¸sÓ C�Iô " #×"9Ñ"9¸)Ó"DÓEˆGØ&-Ð&8ˆC× Ñ ˜sÑ #Ø×!Ñ! #Õ&Ð&øô )ô@ð!$× :Ñ :¸3Ó ?’Ið@úsÁB%Â%CÃCc ó0€V'g \R4hVPR4p\V4^8wd\RV,4h\P \ VP V4R4# \dp\T: RT: 24RhRp?ii;i)z×Turn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. úAddress cannot be emptyÚ.zExpected 4 octets in %rr�ú in N)rr-r.rŸÚ from_bytesÚmapÚ _parse_octetr)rŠr¥ÚoctetsÚexcs&& r r¤Ú_BaseV4._ip_int_from_stringžs†€÷Ü#Ð$=Ó>Ð >à—‘˜cÓ"ˆÜ ˆv‹;˜!Ô Ü#Ð$=ÀÕ$FÓGÐ Gð JÜ—>‘>¤# c×&6Ñ&6¸Ó"?ÀÓGÐ GøÜô JÜ#³#²vÐ$>Ó?ÀTÐ Iûð JúsÁ)A2Á2 BÁ=BÂBc óŠ€V'g \R4hVP4'dVP4'gRp\W!,4h\V4^8”dRp\W!,4hVR8wd"V^,R8XdRp\W!,4h\ V^ 4pV^ÿ8”d\RV,4hV#)zÔConvert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %rz$At most 3 characters permitted in %rréz%Leading zeros are not permitted in %rzOctet %d (> 255) not permitted)rr�ržr.rŸ)rŠÚ octet_strr�Ú octet_ints&& r rœÚ_BaseV4._parse_octet¸s³€÷ÜÐ8Ó9Ð 9à×!Ñ!×#Ò#¨ ×(9Ñ(9×(;Ò(;Ø7ˆCܘS�_Ó-Ð -ô ˆy‹>˜AÔ Ø8ˆCܘS�_Ó-Ð -ð ˜Ô   ¨!¥ °Ô 3Ø9ˆCܘS�_Ó-Ð -ä˜  2Ó&ˆ Ø �sŒ?ÜÐ=À ÕIÓJÐ JØÐr c  ó`€RP\\VP^R444#)zªTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. r˜r�)Újoinr›r,r$)rŠr�s&&r rØÚ_BaseV4._string_from_ip_intÜs%€ð�x‰xœœC §¡°°EÓ!:Ó;Ó<Ð.=óøé€ÐIÑ'H �˜– Ó'HùóƒTFc3ó.<"€TF pSV9x€K R#5ir®rr½s& €r ror¾>óøé€Ð\Ñ/[¨�D –OÓ/[ùrÀrsrssfr ryÚIPv4Address.is_private+sˆø€÷$ ‹CÔI t§¡×'HÒ'HÓI�C�CŠCÔI t§¡×'HÒ'HÓIÓ I÷ ]ð ]ß“Ô\¨t¯©×/[Ò/[Ó\—”ð âð àÔ\¨t¯©×/[Ò/[Ó\Ó\ð r c ód€WPP9;'dVP'*#©a*``True`` if the address is defined as globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exception: For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_global == address.ipv4_mapped.is_global ``is_global`` has value opposite to :attr:`is_private`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. )ruÚ_public_networkryrss&r r|ÚIPv4Address.is_globalAs&€ð Ÿ?™?×:Ñ:Ñ:×RÐRÀ4Ç?Á?Ô?RÐRr c ó2€WPP9#)z�Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )ruÚ_multicast_networkrss&r rVÚIPv4Address.is_multicastSs€ð—‘×9Ñ9Ñ9Ð9r c ó2€WPP8H#)z„Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )ruÚ_unspecified_addressrss&r r€ÚIPv4Address.is_unspecified^s€ð—‘×;Ñ;Ñ;Ð;r c ó2€WPP9#)zuTest if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )ruÚ_loopback_networkrss&r r„ÚIPv4Address.is_loopbackis€ð—‘×8Ñ8Ñ8Ð8r c ó2€WPP9#)zzTest if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )ruÚ_linklocal_networkrss&r riÚIPv4Address.is_link_localss€ð—‘×9Ñ9Ñ9Ð9r c ó€\RV 24#)z_Return the IPv4-mapped IPv6 address. Returns: The IPv4-mapped IPv6 address per RFC 4291. z::ffff:)rrss&r Ú ipv6_mappedÚIPv4Address.ipv6_mapped}s€ô˜W T FÐ+Ó,Ð,r r»N)r4Ú __weakref__)rrrr r r³r°r´r´rdr†Ú lru_cacheryr|rVr€r„rirÕr r¶r·s@r rròsëø‡€á9à&€Iò!6ðFñ*óð*ðñ9óð9ðØ×ÒÓñ óóð ð(Ø×ÒÓñSóóðSð ñ:óð:ðñ<óð<ðñ9óð9ðñ:óð:ðñ-óö-r rcóºa€]tRtRtoRt]P R4tRtRt Rt Rt ] Pt ]R4t]R 4t]R 4t]R 4tR tVtR #)riˆcóè€VPV4wr#\PW4\W#3RR7VnVPP VnVPP VnR#©F)rN)r«rr°rrrr_©rtrr/Úmasks&& r r°ÚIPv4Interface.__init__ŠóT€Ø×,Ñ,¨WÓ5‰ ˆä×јTÔ(Ü" D <¸Ô>ˆŒ Ø—|‘|×+Ñ+ˆŒ ØŸ,™,×1Ñ1ˆŽr có.€VPP#r®©rr$rss&r r$ÚIPv4Interface.hostmask’ó€à�|‰|×$Ñ$Ð$r có^€RVPVP4VP3,#rÿ©rØr4r_rss&r rÙÚIPv4Interface.__str__–s,€Ø˜$×2Ñ2°4·8±8Ó<ØŸ/™/ð+õ+ð +r có¬€\PW4pV\Jg V'gV#VPVP8H# \dR#i;ir)rrÁrlrr`©rtrÀÚ address_equals&& r rÁÚIPv4Interface.__eq__šóN€Ü#×*Ñ*¨4Ó7ˆ Ø œNÓ *·-Ø Ð ð Ø—<‘< 5§=¡=Ñ0Ð 0øÜô òð  úó«AÁ AÁAcóú€\PW4pV\Jd\#VPVP8;'g$VPVP8H;'dT# \dR#i;ir)rrÅrlrr`©rtrÀÚ address_lesss&& r rÅÚIPv4Interface.__lt__¦ss€Ü"×)Ñ)¨$Ó6ˆ Ø œ>Ó )Ü!Ð !ð Ø—L‘L 5§=¡=Ñ0÷CðCØ—L‘L E§M¡MÑ1×BÐB°lð Døäô òð ús§A+Á A+Á(A+Á+ A:Á9A:có€€\VPVP\VPP 434#r®©rÜr4r_rŸrrarss&r rÞÚIPv4Interface.__hash__²ó+€Ü�T—X‘X˜tŸ™´°D·L±L×4PÑ4PÓ0QÐRÓSÐSr có,€\VP4#r®)rr4rss&r r9ÚIPv4Interface.ip·ó€ä˜4Ÿ8™8Ó$Ð$r cóZ€VPVP4: RVP: 2#r,rårss&r r)ÚIPv4Interface.with_prefixlen»ó%€à×2Ñ2°4·8±8Ö<ØŸ/›/ð+ð +r cóZ€VPVP4: RVP: 2#r,©rØr4rrss&r r-ÚIPv4Interface.with_netmaskÀó%€à×2Ñ2°4·8±8Ö<ØŸ,›,ð(ð (r cóZ€VPVP4: RVP: 2#r,©rØr4r$rss&r r0ÚIPv4Interface.with_hostmaskÅó%€à×2Ñ2°4·8±8Ö<ØŸ-›-ð)ð )r ©r_rrN)rrrr r°r†r‡r$rÙrÁrÅrÞrpr±r´r9r)r-r0r r¶r·s@r rrˆs”ø‡€ò2ð×Ññ%óð%ò+ò ò òTð ×*Ñ*€Jà ñ%óð%ðñ+óð+ðñ(óð(ðñ)óö)r rcója€]tRtRtoRt]tRRlt]] P!4R44t Rt Vt R#)riËaIThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 c ó:a€VPV4wop\S4VnVPV4wVnVn\ VP4pV\ VP4,V8wdEV'd\RV,4h\V\ VP4,4VnVP VP^, 8XdVPVn R#VP VP8XdV3RlVn R#R#)a)Instantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.2.0/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. ú%s has host bits setcó.<€\\S434#r®)r2r©r/s€r ÚÚ&IPv4Network.__init__.. 󸀤¤{°4Ó'8Ð&:Ô!;r N) r«rrar”rr_rŸrrHrr ©rtrrrÝr´r/s&&& @r r°ÚIPv4Network.__init__ÚsÞø€ðF×,Ñ,¨WÓ5‰ ˆˆdä*¨4Ó0ˆÔØ(,×(:Ñ(:¸4Ó(@Ñ%ˆŒ �d”oÜ�T×)Ñ)Ó*ˆØ ”C˜Ÿ ™ Ó%Õ %¨Ô /ßÜ Ð!7¸$Õ!>Ó?Ð?ä'2°6Ü36°t·|±|Ó3Dõ4Eó(F�Ô$ð �?‰?˜t×1Ñ1°AÕ5Ô 6ØŸ™ˆDŽJØ �_‰_ ×!3Ñ!3Ô 4Ü;ˆDŽJñ5r c ó®€VP\R49;'dVP\R49'*;'dVP'*#)z™Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. ú 100.64.0.0/10)rarrXryrss&r r|ÚIPv4Network.is_globalsU€ð×)Ñ)¬[¸Ó-IÑI÷KðKØ×*Ñ*¬k¸/Ó.JÑJôL÷$ð$à—O‘OÔ#ð %r ©r_r rraN©T)rrrr r rrr°r´r†rØr|r r¶r·s@r rrËs<ø‡€ñ ð!€Nô2<ðhØ×ÒÓñ %óóö %r rcó^€]tRtRt]!R4t]!R4t]!R4t]!R4t]!R4]!R4]!R4]!R4]!R4]!R 4]!R 4]!R 4]!R 4]!R 4]!R4]!R4]!R4]!R4.t ]!R4]!R4.t ]!R4t ] !R4t RtR#)Ú_IPv4Constantsiz169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4rz 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/24z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z 192.0.0.9/32z 192.0.0.10/32z0.0.0.0rN)rrrr rrÒrÏrÉrÆrvrxr¸rrÌr rr r rrsà†Ù$Ð%5Ó6Ðá# MÓ2Ðá$ ]Ó3Ðá! /Ó2€Oñ �KÓ Ù�LÓ!Ù�MÓ"ÙÐ$Ó%Ù�OÓ$Ù�NÓ#ÙÐ$Ó%Ù�NÓ#ÙÐ$Ó%Ù�OÓ$ÙÐ%Ó&ÙÐ$Ó%Ù�MÓ"ÙÐ(Ó)ð Ðñ$ �NÓ#Ù�OÓ$ð$Ð ñ $ MÓ2Ðá& yÓ1Ôr rcóØa€]tRtRtoRtR t^t^],^, t^t ] !R4t ]t /t ]R4t]R4t]R4t]R4t]RR l4tR tR t]R 4tR tVtR#)Ú_BaseV6iGzmBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. Ú0123456789ABCDEFabcdefc óH€WP9d�\V\4'd0Tp^Tu;8:dVP8:gMVP V4MVP V4p\ VPV44pW23VPV&VPV,#r�)r‘rDrŸrHršr¡rrŒr’s&& r r”Ú_BaseV6._make_netmask[s�€ð ×(Ñ(Ô (ܘ#œs×#Ò#Ø� ؘYÖ;¨#×*;Ñ*;Ö;Ø×/Ñ/° Ô:øà×:Ñ:¸3Ó?� Ü! #×"9Ñ"9¸)Ó"DÓEˆGØ&-Ð&8ˆC× Ñ ˜sÑ #Ø×!Ñ! #Õ&Ð&r c ó¨€V'g \R4h\V4^-8”dFTp\V4^d8”d%VR, R\V4^Z, RVRR 2p\RV: 24hVP^,pVPRVR7p^p\V4V8dR WQ3,p\V4hR VR,9dj\ VP 44P pTPR T^, R ,,4TPR TR ,,4\V4V8”dRV^, V3,p\V4hRp \^\V4^, 4F-p WJ,'dKV eRV,p\V4hT p K/ V eÉT p \V4V , ^, p V^,'g%V ^,p V 'dRp\Wa,4hVR,'g%V ^,p V 'dRp\Wa,4hVPW¼,, p V ^8d'Rp\W`P^, V3,4hMŒ\V4VP8wd Rp\W`PV3,4hV^,'gRp\Wa,4hVR,'gRp\Wa,4h\V4p ^p ^p ^p\V 4F)p V^,pWàPWJ,4,pK+ V^V ,,p\V )^4F)p V^,pWàPWJ,4,pK+ V# \dp\T: R T: 24RhRp?ii;i \dp\T: R T: 24RhRp?ii;i)zÁTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. r—:Né-NrÑz chars elided)Nz"At most 45 characters expected in Ú:)Úmaxsplitz At least %d parts expected in %rr˜r™ú%xéÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %riÓÿÿÿr^) rr.Ú _HEXTET_COUNTr-rrRr4rUrÚ _parse_hextetr)rŠr¥ÚshortenÚ _max_partsÚpartsÚ _min_partsr�Úipv4_intržÚ skip_indexÚiÚparts_hiÚparts_loÚ parts_skippedr�s&& r r¤Ú_BaseV6._ip_int_from_stringosŒ€÷Ü#Ð$=Ó>Ð >Ü ˆv‹;˜Ô ؈GÜ�7‹|˜cÔ!Ø# C�[˜M¨¬3¨v«;°r­>Ð*:¸.ÈÐPSÐPTÈÈÐW�Ü#Ð&HØ'.¡kð%3ó4ð 4ð ×&Ñ&¨Õ*ˆ Ø— ‘ ˜S¨:� Ó6ˆðˆ Ü ˆu‹:˜ Ô "Ø4¸ Ð7KÕKˆCÜ# CÓ(Ð (ð �%˜•)Ô ð NÜ& u§y¡y£{Ó3×7Ñ7�ð �L‰L˜ (¨b¥.°FÕ!:Õ;Ô <Ø �L‰L˜ ¨FÕ!2Õ3Ô 4ô ˆu‹:˜ Ô "Ø5¸ÀA½ÀvÐ8NÕNˆCÜ# CÓ(Ð (ðˆ Ü�qœ#˜e›* q�.Ö)ˆAØ—8–8ØÒ)à<¸vÕE�CÜ+¨CÓ0Ð0Ø’ ñ *ð Ò !à!ˆHܘ5“z JÕ.°Õ2ˆHؘ—8”8ؘA• �ߨL�CÜ+¨C­LÓ9Ð9ؘ—9”9ؘA• �ߨM�CÜ+¨C­LÓ9Ð9Ø×-Ñ-°Õ1DÕEˆMؘqÔ ØG�Ü'¨×/@Ñ/@ÀÕ/BÀFÐ.KÕ(KÓLÐLð!ô�5‹z˜S×.Ñ.Ô.ØD�Ü'¨×/@Ñ/@À&Ð.IÕ(IÓJÐJؘ—8”8ØH�Ü'¨­ Ó5Ð5ؘ—9”9ØI�Ü'¨­ Ó5Ð5ܘ5“zˆH؈H؈Mð JàˆFܘ8–_�ؘ2• �Ø×+Ñ+¨E­HÓ5Õ5’ñ%ð �r˜MÕ)Õ )ˆFܘH˜9 aÖ(�ؘ2• �Ø×+Ñ+¨E­HÓ5Õ5’ñ)ðˆMøôM%ô NÜ'³cº6Ð(BÓCÈÐMûð NûôNô JÜ#³#²vÐ$>Ó?ÀTÐ Iûð Jús1Ã#NÌBN.Î N+ÎN&Î&N+Î. OÎ9O Ï Oc óÆ€VPPV4'g\RV,4h\V4^8”dRp\W!,4h\ V^4#)zæConvert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rz$At most 4 characters permitted in %r)Ú _HEX_DIGITSÚ issupersetrr.rŸ)rŠÚ hextet_strr�s&& r r!Ú_BaseV6._parse_hextetàsX€ð �‰×)Ñ)¨*×5Ò5ÜÐ>ÀÕKÓLÐ Lô ˆz‹?˜QÔ Ø8ˆCܘSÕ-Ó.Ð .ä�:˜rÓ"Ð"r c ó€Rp^pRp^p\V4F0wrgVR8Xd!V^, pVR8XdTpWS8”dTpTpK*K,^pRpK2 V^8”d:VV,pV\V48Xd VR., pR.WV%V^8Xd R.V,pV#)a”Compresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. réÚr^)Ú enumerater.) rŠÚhextetsÚbest_doublecolon_startÚbest_doublecolon_lenÚdoublecolon_startÚdoublecolon_lenÚindexÚhextetÚbest_doublecolon_ends && r Ú_compress_hextetsÚ_BaseV6._compress_hextetsúsÅ€ð""$ÐØ ÐØÐØˆÜ& wÖ/‰MˆEؘŒ}Ø 1Õ$�Ø$¨Ô*à(-Ð%Ø"Ô9à+:Ð(Ø->Ò*ñ:ð #$�Ø$&Ò!ñ0ð  !Ô #Ø$:Ø$8õ%9Ð ð$¤s¨7£|Ô3ؘB˜4•�ØDFÀ4ˆGÐ+?Ð @à%¨Ô*ؘ$ �.�àˆr Nc  ó6€Vf\VP4pWP8”d \R4hRV,p\ ^^ ^4Uu.uFpR\W#V^,^4,NK! ppVP V4pRP V4#uupi)zôTurns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. zIPv6 address is too largeú%032xrr)rŸr4rIrrr=r¥)rŠr�Úhex_strrèr5s&& r rØÚ_BaseV6._string_from_ip_int*sŽ€ð Š>ܘŸ™“\ˆFà —M‘MÔ !ÜÐ8Ó9Ð 9à˜FÕ"ˆÜ;@ÀÀBȼ?ÓK¹?°a�4œ#˜g¨¨!­˜n¨bÓ1×1Ð1¹?ˆÐKà×'Ñ'¨Ó0ˆØ�x‰x˜Ó Ð ùòLsÁ %Bc óð€\V\4'd\VP4pM7\V\4'd\VP 4pM \V4pVP V4pRV,p\^^ ^4Uu.uF qCWD^,NK pp\V\\34'd%RRPV4VP3,#RPV4#uupi)zUExpand a shortened IPv6 address. Returns: A string, the expanded IPv6 address. r@rr) rDrr,rar r9r¤rrir¥r_)rtr¥r�rArèr$s& r rrÚ$_BaseV6._explode_shorthand_ip_stringDsÁ€ô �dœK× (Ò (ܘ×-Ñ-Ó.‰FÜ ˜œm× ,Ò ,ܘŸ™“\‰F䘓YˆFà×)Ñ)¨&Ó1ˆØ˜FÕ"ˆÜ).¨q°"°a¬Ó9© A˜˜Q�3“©ˆÐ9Ü �dœ\¬=Ð9× :Ò :ؘcŸh™h u›o¨t¯©Ð?Õ?Ð ?Ø�x‰x˜‹Ðùò:s C3c ó~€VPRRR1,PRR4pRPV4R,#)zqReturn the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. Nrr3r˜ú .ip6.arpar^)ruÚreplacer¥)rtÚ reverse_charss& r r|Ú_BaseV6._reverse_pointerYs7€ð Ÿ ™ ¡d¨ dÕ+×3Ñ3°C¸Ó<ˆ Ø�x‰x˜ Ó&¨Õ4Ð4r c óŒ€VPR4wrpV'gRpW3#V'dRV9d\RV,4hW3#)z­Helper function to parse IPv6 string address with scope id. See RFC 4007 for details. Args: ip_str: A string, the IPv6 address. Returns: (addr, scope_id) tuple. Ú%NzInvalid IPv6 address: "%r")Ú partitionr)r¥r/ÚsepÚscope_ids& r Ú_split_scope_idÚ_BaseV6._split_scope_idbsO€ð%×.Ñ.¨sÓ3ш�8ߨˆHðˆ~Ð÷˜S Hœ_Ü#Ð$@À6Õ$IÓJÐ J؈~Ðr rr®)rrrr r r³rGÚ IPV6LENGTHrIr Ú frozensetr.rHr‘rµr”r¤r!r=rØrrr|rˆrOr r¶r·s@r rrGsÆø‡€ñð€IØ€GØ�J• !Õ#€IØ€MÙÐ4Ó5€KØ€Mð€Nàñ'óð'ð&ñnJóðnJð`ñ#óð#ð2ñ-óð-ð^ó!óð!ò2ò*5ðñóör rcónaa€]tRtRtoRtRtRtV3RltV3RltRt V3Rlt Rt V3R lt R t ]R 4t]R 4t]R 4t]R4t]R4t]R4t]]P,!4R44t]R4t]R4t]R4t]R4t]R4t]R4tRtVtV;t #)rivz/Represent and manipulate single IPv6 Addresses.c ó¨€\V\4'd!VPV4WnRVnR#\V\ 4'd7VP V^4\PVR4VnRVnR#\V4pRV9d\RV: 24hVPV4wq nVPV4VnR#)a¬Instantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nr�r+r­) rDrŸr‚r4Ú _scope_idr©r‡ršr,rrOr¤r®s&& r r°ÚIPv6Address.__init__|sµ€ô$ �gœs× #Ò #Ø × #Ñ # GÔ ,ØŒHØ!ˆDŒNÙ ô �gœu× %Ò %Ø × &Ñ & w°Ô 3Ü—~‘~ g¨uÓ5ˆDŒHØ!ˆDŒNÙ ô�w“<ˆØ �(Œ?Ü#Ð&8¸¹ Ð$DÓEÐ EØ#'×#7Ñ#7¸Ó#AÑ ˆ”.à×+Ñ+¨HÓ5ˆŽr cót<€VPpVf\SV` 4#^p\SV` 4pVRV V: 2#r®)Ú ipv4_mappedrïrr)rtrXÚ prefix_lenÚraw_exploded_strr°s& €r rrÚ(IPv6Address._explode_shorthand_ip_string¤sLø€Ø×&Ñ&ˆ Ø Ò Ü‘7Ñ7Ó9Ð 9؈ Ü ™7Ñ?ÓAÐØ" ; JÐ/Ð0°±Ð@Ð@r cóð<€VPpVf\SV` 4#^p\SV` 4RVpVPpV VR 2RRR1,P RR4pRP V4R,#)NÚ008xrr3r˜rFr^)rXrïr|rrr4rGr¥)rtrXrYrZr&rHr°s& €r r|ÚIPv6Address._reverse_pointer¬s�ø€Ø×&Ñ&ˆ Ø Ò Ü‘7Ñ+Ó-Ð -؈ Ü ™7Ñ?ÓAÀ+À:ÐNÐà—?‘?ˆØ+Ð,¨X°d¨OÐ<¹T¸r¸TÕB×JÑJÈ3ÐPRÓSˆ Ø�x‰x˜ Ó&¨Õ4Ð4r c óÀ€VPpVf\R\V4,4hVP^ , pVP V4: R\V4: 2#)a�Return convenient text representation of IPv4-mapped IPv6 address See RFC 4291 2.5.5.2, 2.2 p.3 for details. Returns: A string, 'x:x:x:x:x:x:d.d.d.d', where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation) as defined in RFC 4291 2.2 p.3. z0Can not apply to non-IPv4-mapped IPv6 address %sr)rXrr,r4rØ)rtrXÚhigh_order_bitss& r Ú_ipv4_mapped_ipv6_to_strÚ$IPv6Address._ipv4_mapped_ipv6_to_str·sU€ð×&Ñ&ˆ Ø Ò Ü#Ð$VÔY\Ð]aÓYbÕ$bÓcÐ cØŸ(™( b�.ˆØ×2Ñ2°?ÖCÄSÈÕEUÐVÐVr có¾<€VPpVf\SV` 4pMVP4pVP'dVR,VP,#T#)NrK)rXrïrÙrarU)rtrXr¥r°s& €r rÙÚIPv6Address.__str__ÉsNø€Ø×&Ñ&ˆ Ø Ò Ü‘W‘_Ó&‰Fà×2Ñ2Ó4ˆFØ04··°ˆv˜�|˜dŸn™nÕ,ÐJÀFÐJr cóD€\VPVP34#r®)rÜr4rUrss&r rÞÚIPv6Address.__hash__Ñs€Ü�T—X‘X˜tŸ~™~Ð.Ó/Ð/r cóŠ<€\SV`V4pV\Jd\#V'gR#VP\ VRR48H#)FrUN)rïrÁrlrUÚgetattr)rtrÀrér°s&& €r rÁÚIPv6Address.__eq__Ôs=ø€Ü™™ uÓ-ˆ Ø œNÓ *Ü!Ð !ßÙØ�~‰~¤¨° ¸TÓ!BÑBÐBr có2€VP\V433#r®r¯rss&r r±ÚIPv6Address.__reduce__Üs€Ø—‘¤ T£  Ð-Ð-r c ó€VP#)z¨Identifier of a particular zone of the address's scope. See RFC 4007 for details. Returns: A string identifying the zone of the address if specified, else None. )rUrss&r rNÚIPv6Address.scope_idßs€ð�~‰~Ðr c ó,€\VP4#r³)r)r4rss&r r´ÚIPv6Address.packedër¶r c ój€VPpVe VP#WPP9#rU)rXrVrurÉ©rtrXs& r rVÚIPv6Address.is_multicastðs4€ð×&Ñ&ˆ Ø Ò "Ø×+Ñ+Ð +Ø—‘×9Ñ9Ñ9Ð9r c óa€SPpVe VP#\;QJd3V3RlSPP4F 'gK R# R#!V3RlSPP44#)rcc3ó.<"€TF pSV9x€K R#5ir®r)rmrèrts& €r roÚ*IPv6Address.is_reserved.. søé€ÐIÑ&H �4˜1–9Ó&HùrÀTF)rXrdrtruÚ_reserved_networksrqsf r rdÚIPv6Address.is_reservedþs_ø€ð×&Ñ&ˆ Ø Ò "Ø×*Ñ*Ð *ß‹sÔI d§o¡o×&HÒ&HÓI�sŒsÐIŠsÐIˆsÔI d§o¡o×&HÒ&HÓIÓIÐIr c ój€VPpVe VP#WPP9#rh)rXrirurÒrqs& r riÚIPv6Address.is_link_local s4€ð×&Ñ&ˆ Ø Ò "Ø×,Ñ,Ð ,Ø—‘×9Ñ9Ñ9Ð9r c ó2€WPP9#©a0Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )ruÚ_sitelocal_networkrss&r Ú is_site_localÚIPv6Address.is_site_locals€ð—‘×9Ñ9Ñ9Ð9r c óÔa€SPpVe VP#\;QJd3V3RlSPP4F 'gK RM( RM$!V3RlSPP44;'dc\ ;QJd3V3RlSPP 4F 'dK R# R#!V3RlSPP 44#)r»c3ó.<"€TF pSV9x€K R#5ir®rr½s& €r roÚ)IPv6Address.is_private..<r¿rÀTFc3ó.<"€TF pSV9x€K R#5ir®rr½s& €r ror�=rÂrÀ)rXryrtrurvrwrxrqsf r ryÚIPv6Address.is_private's¥ø€ð"×&Ñ&ˆ Ø Ò "Ø×)Ñ)Ð )ç ‹CÔI t§¡×'HÒ'HÓI�C�CŠCÔI t§¡×'HÒ'HÓIÓ I÷ ]ð ]ß“Ô\¨t¯©×/[Ò/[Ó\—”ð âð àÔ\¨t¯©×/[Ò/[Ó\Ó\ð r c ó\€VPpVe VP#VP'*#rÅ)rXr|ryrqs& r r|ÚIPv6Address.is_global@s.€ð×&Ñ&ˆ Ø Ò "Ø×(Ñ(Ð (Ø—?‘?Ô"Ð"r c óX€VPpVe VP#VP^8H#r)rXr€r4rqs& r r€ÚIPv6Address.is_unspecifiedTs/€ð×&Ñ&ˆ Ø Ò "Ø×-Ñ-Ð -Ø�x‰x˜1‰}Ðr c óX€VPpVe VP#VP^8H#rƒ)rXr„r4rqs& r r„ÚIPv6Address.is_loopbackbs/€ð×&Ñ&ˆ Ø Ò "Ø×*Ñ*Ð *Ø�x‰x˜1‰}Ðr c ón€VP^ , R8wdR#\VPR,4#)z–Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. rNìÿÿ©r4rrss&r rXÚIPv6Address.ipv4_mappedps+€ð �H‰H˜�N˜vÔ %Ùܘ4Ÿ8™8 jÕ0Ó1Ð1r c ó¶€VP^`, R8wdR#\VP^@, R,4\VP(R,43#)z³Tuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) i Nr‹rŒrss&r ÚteredoÚIPv6Address.teredo}sI€ð �H‰H˜�N˜zÔ )ÙܘTŸX™X¨�^¨zÕ9Ó:ܘTŸX™X˜I¨ Õ2Ó3ð5ð 5r c ó|€VP^p, R8wdR#\VP^P, R,4#)z®Return the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. i Nr‹rŒrss&r Ú sixtofourÚIPv6Address.sixtofourŒs/€ð �H‰H˜�O Ô &ÙܘDŸH™H¨�N¨jÕ8Ó9Ð9r )r4rU)r4rUr×)!rrrr r r³r°rrr|rarÙrÞrÁr±r´rNr´rVrdrir}r†rØryr|r€r„rXr�r’r r¶rùrús@@r rrvsVù‡€á9à3€Iò&6õPAõ 5òWõ$Kò0õCò.ðñ óð ðñ*óð*ðñ :óð :ðñ Jóð Jðñ :óð :ðñ :óð :ðØ×ÒÓñ óóð ð.ñ#óð#ð&ñ óð ðñ óð ðñ 2óð 2ðñ 5óð 5ðñ :ó÷ :ð :r rcóìaa€]tRtRtoRt]P R4tV3RltRt Rt Rt ] Pt ]R4t]R 4t]R 4t]R 4t]R 4t]V3R l4tRtVtV;t#)r išcóè€VPV4wr#\PW4\W#3RR7VnVPP VnVPP VnR#rÛ)r«rr°rrrr_rÜs&& r r°ÚIPv6Interface.__init__œrßr có.€VPP#r®rárss&r r$ÚIPv6Interface.hostmask¤rãr cóF<€R\SV`4VP3,#rÿ)rïrÙr_©rtr°s&€r rÙÚIPv6Interface.__str__¨s%ø€Øœ%™'™/Ó+ØŸ/™/ð+õ+ð +r có¬€\PW4pV\Jg V'gV#VPVP8H# \dR#i;ir)rrÁrlrr`rès&& r rÁÚIPv6Interface.__eq__¬rërìcóò€\PW4pV\JdV#VPVP8;'g$VPVP8H;'dT# \dR#i;ir)rrÅrlrr`rîs&& r rÅÚIPv6Interface.__lt__¸ss€Ü"×)Ñ)¨$Ó6ˆ Ø œ>Ó )ØÐ ð Ø—L‘L 5§=¡=Ñ0÷CðCØ—L‘L E§M¡MÑ1×BÐB°lð Døäô òð ús£A'Á A'Á$A'Á' A6Á5A6có€€\VPVP\VPP 434#r®ròrss&r rÞÚIPv6Interface.__hash__Ärôr có,€\VP4#r®)rr4rss&r r9ÚIPv6Interface.ipÉr÷r cóZ€VPVP4: RVP: 2#r,rårss&r r)ÚIPv6Interface.with_prefixlenÍrúr cóZ€VPVP4: RVP: 2#r,rürss&r r-ÚIPv6Interface.with_netmaskÒrþr cóZ€VPVP4: RVP: 2#r,rrss&r r0ÚIPv6Interface.with_hostmask×rr có\€VP^8H;'dVPP#)r€)r4rr€rss&r r€ÚIPv6Interface.is_unspecifiedÜs"€à�x‰x˜1‰}×<Ð< §¡×!<Ñ!<Ð.# r r N) r«rrar”rr_rŸrrHrr r s&&& @r r°ÚIPv6Network.__init__õsÝø€ð>×,Ñ,¨WÓ5‰ ˆˆdä*¨4Ó0ˆÔØ(,×(:Ñ(:¸4Ó(@Ñ%ˆŒ �d”oÜ�T×)Ñ)Ó*ˆØ ”C˜Ÿ ™ Ó%Õ %¨Ô /ßÜ Ð!7¸$Õ!>Ó?Ð?ä'2°6Ü36°t·|±|Ó3Dõ4Eó(F�Ô$ð �?‰?˜t×1Ñ1°AÕ5Ô 6ØŸ™ˆDŽJØ �_‰_ × 2Ñ 2Ô 2Ü;ˆDŽJñ3r c# óÊ"€\VP4p\VP4p\V^,V^,4FpVP V4x€K R#5i)z†Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. Nrrs& r r ÚIPv6Network.hosts% sQé€ô�d×*Ñ*Ó+ˆÜ˜×.Ñ.Ó/ˆ Ü�w •{ I°¥MÖ2ˆAØ×%Ñ% aÓ(Ô (ó3ùs‚A!A#c ój€VPP;'dVPP#r{)rar}rXrss&r r}ÚIPv6Network.is_site_local1 s1€ð×$Ñ$×2Ñ2÷5ð5Ø×&Ñ&×4Ñ4ð 6r rNr) rrrr r rrr°r r´r}r r¶r·s@r rrås0ø‡€ñ ð!€Nô.<ò` )ðñ 6óö 6r rcó€]tRtRt]!R4t]!R4t]!R4]!R4]!R4]!R4]!R4]!R 4]!R 4]!R 4]!R 4]!R 4]!R4. t]!R4]!R4]!R4]!R4]!R4]!R4.t]!R4]!R4]!R4]!R4]!R4]!R4]!R4]!R4]!R4]!R4]!R4]!R4]!R 4]!R!4]!R"4.t ]!R#4t R$t R%#)&Ú_IPv6ConstantsiA z fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z64:ff9b:1::/48z100::/64z 2001::/23z 2001:db8::/32z 2002::/16z 3fff::/20zfc00::/7z 2001:1::1/128z 2001:1::2/128z 2001:3::/32z2001:4:112::/48z 2001:20::/28z 2001:30::/28z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10rN) rrrr rrÒrÉrvrxrvr|r rr r r¸r¸A s>†á$ [Ó1Ðá$ ZÓ0Ðñ �IÓÙ�HÓÙ�OÓ$ÙÐ$Ó%Ù�JÓÙ�KÓ Ù�OÓ$á�KÓ á�KÓ Ù�JÓÙ�KÓ ð Ðñ" �OÓ$Ù�OÓ$Ù�MÓ"ÙÐ%Ó&Ù�NÓ#Ù�NÓ#ð $Ð ñ �FÓ™[¨Ó3Ù�IÓ¡ ¨IÓ 6Ù�IÓ¡ ¨JÓ 7Ù�JÓ¡¨ZÓ!8Ù�JÓ¡¨ZÓ!8Ù�JÓ¡¨ZÓ!8Ù�JÓ¡¨ZÓ!8Ù�JÓð Ðñ% [Ó1Ôr r¸r)%r Ú __version__r†rªrQrrrrrr!r&r)r0r:r@rOr\rgrnrprëÚtotal_orderingrErirŠrurŒrrrrrrr rr¸rr r Úr»s¨ðñð€ óà € Ø € ô0˜ ô0ô0˜ ô0òSô:Sò:UòDCò( Cò òò( :ò 4òn.òb36òl÷2j,ñj,ðZ€à ×ÑôhN�>óhNóðhNðV ×ÑôH4�>óH4óðH4÷Vñð )€ Ô÷B:ñB:ôHS-�'˜<ôS-ôl@)�Kô@)ôFO%�'˜<ôO%÷d#2ñ#2ðL(€ ÔØ'€ Ô÷mñmô^ a:�'˜<ôa:ôH H@�KôH@ôVY6�'˜<ôY6÷x,2ñ,2ð^(€ ÔØ'€ Ör