grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/20263 ¡ ft:ã @sldZddlZddlZddlZyddlZdZWnek rDdZYnXddgZGdd„deƒZ dZ d Z d Z d Z e e Zd ZGd d„dƒZer¦Gdd„deƒZejdƒedk�rhddlZeejdƒZeejƒƒejejdƒejejdƒejƒejƒ\ZZxXededƒD]FZ ej!e ƒ\Z"Z#Z$ede ƒxe#D]Z%ede%ƒ�qd5d6„Z#d7d8„Z$d9d:„Z%d?d;d<„Z&dS)@raPThis class supports both the minimal and optional command sets. Arguments can be strings or integers (where appropriate) (e.g.: retr(1) and retr('1') both work equally well. Minimal Command Set: USER name user(name) PASS string pass_(string) STAT stat() LIST [msg] list(msg = None) RETR msg retr(msg) DELE msg dele(msg) NOOP noop() RSET rset() QUIT quit() Optional Commands (some servers support these): RPOP name rpop(name) APOP name digest apop(name, digest) TOP msg n top(msg, n) UIDL [msg] uidl(msg = None) CAPA capa() STLS stls() UTF8 utf8() Raises one exception: 'error_proto'. Instantiate with: POP3(hostname, port=110) NB: the POP protocol locks the mailbox from user authorization until QUIT, so be sure to get in, suck the messages, and quit, each time you access the mailbox. POP is a line-based protocol, which means large mail messages consume lots of python cycles reading them line-by-line. If it's available on your mail server, use IMAP4 instead, it doesn't suffer from the two problems above. zUTF-8cCs@||_||_d|_|j|ƒ|_|jjdƒ|_d|_|jƒ|_ dS)NFÚrbr) ÚhostÚportÚ_tls_establishedÚ_create_socketÚsockÚmakefileÚfileÚ _debuggingÚ_getrespÚwelcome)Úselfr rÚtimeoutrrrÚ__init__as z POP3.__init__cCstj|j|jf|ƒS)N)ÚsocketZcreate_connectionr r)rrrrrrkszPOP3._create_socketcCs,|jdkrtdt|ƒƒ|jj|tƒdS)Néz*put*)rÚprintÚreprrZsendallÚCRLF)rÚlinerrrÚ_putlinens z POP3._putlinecCs.|jrtdt|ƒƒt||jƒ}|j|ƒdS)Nz*cmd*)rrrÚbytesÚencodingr )rrrrrÚ_putcmdus z POP3._putcmdcCs |jjtdƒ}t|ƒtkr$tdƒ‚|jdkr)cCs\t||jƒ}|jj|jƒ}|s&tdƒ‚ddl}|jdƒ|}|j|ƒj ƒ}|j d||fƒS)a Authorisation - only possible if server has supplied a timestamp in initial greeting. Args: user - mailbox user; password - mailbox password. NB: mailbox is locked by server from here to 'quit()' z!-ERR APOP not supported by serverrNrz APOP %s %s) r!r"Ú timestampÚmatchrrÚhashlibÚgroupZmd5Z hexdigestr5)rr:ZpasswordZsecretÚmrMZdigestrrrÚapop9s z POP3.apopcCs|jd||fƒS)z­Retrieve message header of message number 'which' and first 'howmuch' lines of message body. Result is in form ['response', ['line', ...], octets]. z TOP %s %s)r6)rr?ZhowmuchrrrÚtopNszPOP3.topcCs |dk r|jd|ƒS|jdƒS)zìReturn message digest (unique id) list. If 'which', result contains unique id for that message in the form 'response mesgnum uid', otherwise result is the list ['response', ['mesgnum uid', ...], octets] NzUIDL %sZUIDL)r5r6)rr?rrrÚuidlWsz POP3.uidlcCs |jdƒS)zITry to enter UTF-8 mode (see RFC 6856). Returns server response. ZUTF8)r5)rrrrÚutf8csz POP3.utf8c Cstdd„}i}y8|jdƒ}|d}x |D]}||ƒ\}}|||<q&WWn*tk rn}ztdƒ‚WYdd}~XnX|S)aReturn server capabilities (RFC 2449) as a dictionary >>> c=poplib.POP3('localhost') >>> c.capa() {'IMPLEMENTATION': ['Cyrus', 'POP3', 'server', 'v2.2.12'], 'TOP': [], 'LOGIN-DELAY': ['0'], 'AUTH-RESP-CODE': [], 'EXPIRE': ['NEVER'], 'USER': [], 'STLS': [], 'PIPELINING': [], 'UIDL': [], 'RESP-CODES': []} >>> Really, according to RFC 2449, the cyrus folks should avoid having the implementation split into multiple arguments... cSs"|jdƒjƒ}|d|dd…fS)NÚasciirr)Údecoder<)rZlstrrrÚ _parsecapvszPOP3.capa.._parsecapZCAPArz!-ERR CAPA not supported by serverN)r6r) rrVÚcapsr/ZrawcapsZcaplineZcapnmZcapargsZ_errrrrÚcapais    z POP3.capacCsxts tdƒ‚|jrtdƒ‚|jƒ}d|kr2tdƒ‚|dkrBtjƒ}|jdƒ}|j|j|j d�|_|jj dƒ|_ d|_|S) z{Start a TLS session on the active connection as specified in RFC 2595. context - a ssl.SSLContext z-ERR TLS support missingz$-ERR TLS session already establishedZSTLSz!-ERR STLS not supported by serverN)Úserver_hostnamer T) ÚHAVE_SSLrrrXÚsslÚ_create_stdlib_contextr5Ú wrap_socketrr rr)rÚcontextrWr/rrrÚstls†s  z POP3.stls)N)N)N)'rrrÚ__doc__r"Ú POP3_PORTrÚ_GLOBAL_DEFAULT_TIMEOUTrrr r#r,rr4r5r6r7r9r:r;r>r3r@rArBrCrErDrJÚreÚcompilerKrPrQrRrSrXr_rrrrr2s@+       c@s8eZdZdZeddejdfdd„Zdd„Zd dd„Z dS) ÚPOP3_SSLaPOP3 client class over SSL connection Instantiate with: POP3_SSL(hostname, port=995, keyfile=None, certfile=None, context=None) hostname - the hostname of the pop3 over ssl server port - port number keyfile - PEM formatted file that contains your private key certfile - PEM formatted certificate chain file context - a ssl.SSLContext See the methods of the parent class POP3 for more documentation. NcCs’|dk r|dk rtdƒ‚|dk r0|dk r0tdƒ‚|dk s@|dk rVddl}|jdtdƒ||_||_|dkrxtj||d�}||_t j ||||ƒdS)Nz4context and keyfile arguments are mutually exclusivez5context and certfile arguments are mutually exclusiverzAkeyfile and certfile are deprecated, use a custom context insteadr$)ÚcertfileÚkeyfile) Ú ValueErrorÚwarningsÚwarnÚDeprecationWarningrgrfr[r\r^rr)rr rrgrfrr^rirrrr­szPOP3_SSL.__init__cCs"tj||ƒ}|jj||jd�}|S)N)rY)rrr^r]r )rrrrrrrÁs  zPOP3_SSL._create_socketcCs tdƒ‚dS)z¬The method unconditionally raises an exception since the STLS command doesn't make any sense on an already established SSL/TLS session. z$-ERR TLS session already establishedN)r)rrgrfr^rrrr_Çsz POP3_SSL.stls)NNN) rrrr`Ú POP3_SSL_PORTrrbrrr_rrrrrežs  reÚ__main__rr$éz Message %d:z z-----------------------)'r`rGrcrr[rZÚ ImportErrorÚ__all__Ú Exceptionrrarlr*ZLFrr(rrer2rÚsysÚargvÚarr7r:r;r3r>ZnumMsgsZ totalSizeÚrangeÚir@ÚheaderÚmsgr+rrErrrrÚsJ  l0