grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026î ¤ f®ã@sîdZdZddlZdZdZGdd„deƒZGdd „d eƒZd d „Zd d d„Z dd„Z dd„Z dd„Z dd„Z dd„Zdd„Zdd„Zdd„Zdd „Zd!d"„ZGd#d$„d$ƒZejGd%d&„d&eƒƒZejGd'd(„d(eƒƒZGd)d*„d*ƒZGd+d,„d,eeƒZGd-d.„d.eƒZGd/d0„d0eeƒZGd1d2„d2ƒZGd3d4„d4eeƒZGd5d6„d6eƒZGd7d8„d8eeƒZdS)9z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€c@seZdZdZdS)ÚAddressValueErrorz%A Value Error related to the address.N)Ú__name__Ú __module__Ú __qualname__Ú__doc__©r r ú./opt/alt/python34/lib64/python3.4/ipaddress.pyrs rc@seZdZdZdS)ÚNetmaskValueErrorz%A Value Error related to the netmask.N)rrrrr r r r r s r cCsfyt|ƒSWnttfk r(YnXyt|ƒSWnttfk rQYnXtd|ƒ‚dS)a®Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z0%r does not appear to be an IPv4 or IPv6 addressN)Ú IPv4Addressrr Ú IPv6AddressÚ ValueError)Úaddressr r r Ú ip_addresssrTcCslyt||ƒSWnttfk r+YnXyt||ƒSWnttfk rWYnXtd|ƒ‚dS)aÐTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z0%r does not appear to be an IPv4 or IPv6 networkN)Ú IPv4Networkrr Ú IPv6Networkr)rÚstrictr r r Ú ip_network9srcCsfyt|ƒSWnttfk r(YnXyt|ƒSWnttfk rQYnXtd|ƒ‚dS)agTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z2%r does not appear to be an IPv4 or IPv6 interfaceN)Ú IPv4Interfacerr Ú IPv6Interfacer)rr r r Ú ip_interfaceWsrc Cs/y|jddƒSWntdƒ‚YnXdS)a`Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éÚbigz&Address negative or too large for IPv4N)Úto_bytesr)rr r r Úv4_int_to_packedzsrc Cs/y|jddƒSWntdƒ‚YnXdS)zõRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. érz&Address negative or too large for IPv6N)rr)rr r r Úv6_int_to_packedŽs rcCs>t|ƒjdƒ}t|ƒdkr:td|ƒ‚n|S)zAHelper to split the netmask and raise AddressValueError if neededú/ézOnly one '/' permitted in %r)ÚstrÚsplitÚlenr)rÚaddrr r r Ú_split_optional_netmaskžsr$cCsS|d}}x8|dd…D]&}|j|jdkrD|}qPqW||fS)z¼Find a sequence of IPv#Address. Args: addresses: a list of IPv#Address objects. Returns: A tuple containing the first and last IP addresses in the sequence. réN)Ú_ip)Ú addressesÚfirstÚlastÚipr r r Ú_find_address_range¦s  r+cCs=|dkr|Sx&t|ƒD]}||?d@r|SqW|S)zåCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr%)Úrange)ZnumberÚbitsÚir r r Ú_count_righthand_zero_bits¹s r/ccs^t|tƒot|tƒs-tdƒ‚n|j|jkrXtd||fƒ‚n||krstdƒ‚n|jdkr‹t}n$|jdkr£t}n tdƒ‚|j}|j}|j}x�||krYt t ||ƒ||dj ƒdƒ}|d|||fƒ}|V|d|>7}|d|j krGPn|j |ƒ}qÍWd S) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksz%%s and %s are not of the same versionz*last IP address must be greater than firstrézunknown IP versionr%z%s/%dN)Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ_max_prefixlenr&Úminr/Ú bit_lengthÚ _ALL_ONESÚ __class__)r(r)r*Zip_bitsZ first_intZlast_intZnbitsZnetr r r Úsummarize_address_rangeÍs2       r:cCsÙxÒd}g}d}x©|D]¡}|s>|}|j|ƒq|j|jkrk|j|jkrkd}q|t|jƒjƒƒdkrª|jƒ|d<}d}q|}|j|ƒqW|}|s|SqWdS)avLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_recursive([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. NFTr%éÿÿÿÿ)ÚappendÚnetwork_addressÚbroadcast_addressÚlistÚsupernetÚsubnets)r'Z last_addrZ ret_arrayZ optimizedZcur_addrr r r Ú_collapse_addresses_recursives&  " rBc Csód}g}g}g}x3|D]+}t|tƒr}|rm|dj|jkrmtd||dfƒ‚n|j|ƒq|j|jkr|rÈ|dj|jkrÈtd||d fƒ‚ny|j|jƒWqJtk r|j|j ƒYqJXq|r=|d j|jkr=td||d fƒ‚n|j|ƒqWt t |ƒƒ}t t |ƒƒ}x[|t |ƒkrÏt ||d…ƒ\}}|j|ƒd}|jt||ƒƒquWttt ||dtjƒƒƒS) aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterator of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. rr%z%%s and %s are not of the same versionNÚkeyr;r;r;r;r;r;)r1r2Ú_versionr3r<Ú _prefixlenr5r*ÚAttributeErrorr=ÚsortedÚsetr"r+ÚindexÚextendr:ÚiterrBÚ _BaseNetworkÚ_get_networks_key)r'r.ZaddrsZipsZnetsr*r(r)r r r Úcollapse_addresses5s<   rNcCs6t|tƒr|jƒSt|tƒr2|jƒStS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )r1rLrMr2Ú_get_address_keyÚNotImplemented)Úobjr r r Úget_mixed_type_keyns   rRc@s eZdZdZedd„ƒZedd„ƒZedd„ƒZdd „Zd d „Z d d „Z dd„Z dd„Z dd„Z dd„ZdS)Ú_IPAddressBasezThe mother class.cCs |jƒS)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string)Úselfr r r Úexploded‹sz_IPAddressBase.explodedcCs t|ƒS)z;Return the shorthand version of the IP address as a string.)r )rUr r r Ú compressed�sz_IPAddressBase.compressedcCs#dt|ƒf}t|ƒ‚dS)Nz%200s has no version specified)ÚtypeÚNotImplementedError)rUÚmsgr r r r4•sz_IPAddressBase.versioncCsi|dkr.d}t|||jfƒ‚n||jkred}t|||j|jfƒ‚ndS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrDr8r5)rUrrZr r r Ú_check_int_addressšs z!_IPAddressBase._check_int_addresscCsDt|ƒ}||kr@d}t|||||jfƒ‚ndS)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r"rrD)rUrZ expected_lenZ address_lenrZr r r Ú_check_packed_address£s    z$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )r8)rUÚ prefixlenr r r Ú_ip_int_from_prefixªs z"_IPAddressBase._ip_int_from_prefixc Cst||jƒ}|j|}||?}d|>d}||kr{|jd}|j|dƒ}d}t||ƒ‚n|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r%érz&Netmask pattern %r mixes zeroes & ones)r/r5rr) rUÚip_intZtrailing_zeroesr]Z leading_onesZall_onesZbyteslenZdetailsrZr r r Ú_prefix_from_ip_int¶s      z"_IPAddressBase._prefix_from_ip_intcCsd|}t|ƒd‚dS)Nz%r is not a valid netmask)r )rUZ netmask_strrZr r r Ú_report_invalid_netmaskÎs z&_IPAddressBase._report_invalid_netmaskc Cs‡tjj|ƒs"|j|ƒnyt|ƒ}Wntk rS|j|ƒYnXd|kon|jknsƒ|j|ƒn|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)Ú_BaseV4Ú_DECIMAL_DIGITSÚ issupersetrbÚintrr5)rUZ prefixlen_strr]r r r Ú_prefix_from_prefix_stringÒs z)_IPAddressBase._prefix_from_prefix_stringcCsŸy|j|ƒ}Wntk r4|j|ƒYnXy|j|ƒSWntk rZYnX||jN}y|j|ƒSWntk rš|j|ƒYnXdS)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrrbrarr8)rUÚip_strr`r r r Ú_prefix_from_ip_stringês     z%_IPAddressBase._prefix_from_ip_stringN)rrrrÚpropertyrVrWr4r[r\r^rarbrgrjr r r r rS‡s     rSc@sŽeZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z dS)r2z€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. cCs9t|tƒ r5dt|ƒkr5td|ƒ‚ndS)NrzUnexpected '/' in %r)r1Úbytesr r)rUrr r r Ú__init__sz_BaseAddress.__init__cCs|jS)N)r&)rUr r r Ú__int__sz_BaseAddress.__int__c CsCy&|j|jko$|j|jkSWntk r>tSYnXdS)N)r&rDrFrP)rUÚotherr r r Ú__eq__s  z_BaseAddress.__eq__cCsdt|tƒstS|j|jkr>td||fƒ‚n|j|jkr`|j|jkSdS)Nz%%s and %s are not of the same versionF)r1r2rPrDr3r&)rUror r r Ú__lt__$sz_BaseAddress.__lt__cCs*t|tƒstS|jt|ƒ|ƒS)N)r1rfrPr9)rUror r r Ú__add__0sz_BaseAddress.__add__cCs*t|tƒstS|jt|ƒ|ƒS)N)r1rfrPr9)rUror r r Ú__sub__5sz_BaseAddress.__sub__cCsd|jjt|ƒfS)Nz%s(%r))r9rr )rUr r r Ú__repr__:sz_BaseAddress.__repr__cCst|j|jƒƒS)N)r Ú_string_from_ip_intr&)rUr r r Ú__str__=sz_BaseAddress.__str__cCsttt|jƒƒƒS)N)ÚhashÚhexrfr&)rUr r r Ú__hash__@sz_BaseAddress.__hash__cCs |j|fS)N)rD)rUr r r rOCsz_BaseAddress._get_address_keyN)rrrrrmrnrprqrrrsrtrvryrOr r r r r2 s         r2c@sðeZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z dd„Zedd„ƒZedd„ƒZedd„ƒZedd„ƒZed d!„ƒZed"d#„ƒZed$d%„ƒZed&d'„ƒZd(d)„Zd*d+„Zd,d-„Zd.d/d0d1„Zd.d/d2d3„Zed4d5„ƒZed6d7„ƒZed8d9„ƒZed:d;„ƒZ ed<d=„ƒZ!ed>d?„ƒZ"ed@dA„ƒZ#d/S)BrLz~A generic IP network object. This IP class contains the version independent methods which are used by networks. cCs i|_dS)N)Ú_cache)rUrr r r rmPsz_BaseNetwork.__init__cCsd|jjt|ƒfS)Nz%s(%r))r9rr )rUr r r rtSsz_BaseNetwork.__repr__cCsd|j|jfS)Nz%s/%d)r=r])rUr r r rvVsz_BaseNetwork.__str__ccsNt|jƒ}t|jƒ}x)t|d|ƒD]}|j|ƒVq2WdS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r%N)rfr=r>r,Ú_address_class)rUÚnetworkÚ broadcastÚxr r r ÚhostsYsz_BaseNetwork.hostsccsNt|jƒ}t|jƒ}x)t||dƒD]}|j|ƒVq2WdS)Nr%)rfr=r>r,r{)rUr|r}r~r r r Ú__iter__esz_BaseNetwork.__iter__cCsŒt|jƒ}t|jƒ}|dkrT|||krCt‚n|j||ƒS|d7}|||krwt‚n|j||ƒSdS)Nrr%)rfr=r>Ú IndexErrorr{)rUÚnr|r}r r r Ú __getitem__ks    z_BaseNetwork.__getitem__cCs†t|tƒstS|j|jkr>td||fƒ‚n|j|jkr`|j|jkS|j|jkr‚|j|jkSdS)Nz%%s and %s are not of the same versionF)r1rLrPrDr3r=Únetmask)rUror r r rqxsz_BaseNetwork.__lt__c CsayD|j|jkoB|j|jkoBt|jƒt|jƒkSWntk r\tSYnXdS)N)rDr=rfr„rFrP)rUror r r rp„s   z_BaseNetwork.__eq__cCs tt|jƒt|jƒAƒS)N)rwrfr=r„)rUr r r ryŒsz_BaseNetwork.__hash__cCs`|j|jkrdSt|tƒr)dSt|jƒt|jƒkoYt|jƒkSSdS)NF)rDr1rLrfr=r&r>)rUror r r Ú __contains__�s  z_BaseNetwork.__contains__cCs:|j|kp9|j|kp9|j|kp9|j|kS)z*Tell if self is partly contained in other.)r=r>)rUror r r Úoverlapsœsz_BaseNetwork.overlapscCsW|jjdƒ}|dkrS|jt|jƒt|jƒBƒ}||jd)rzÚgetr{rfr=Úhostmask)rUr~r r r r>£s  z_BaseNetwork.broadcast_addresscCsQ|jjdƒ}|dkrM|jt|jƒ|jAƒ}||jdr=)rUr r r Ú num_addressesÀsz_BaseNetwork.num_addressescCs#dt|ƒf}t|ƒ‚dS)Nz%%200s has no associated address class)rXrY)rUrZr r r r{Åsz_BaseNetwork._address_classcCs|jS)N)rE)rUr r r r]Ísz_BaseNetwork.prefixlenccsÉ|j|jks+td||fƒ‚nt|tƒsMtd|ƒ‚n|j|jkon|j|jksŠtd||fƒ‚n||krŸt‚n|jd|j|j fƒ}|j ƒ\}}x±||krƒ||krƒ|j|jkr)|j|jkr)|V|j ƒ\}}qÓ|j|jkrg|j|jkrg|V|j ƒ\}}qÓt d|||fƒ‚qÓW||kr˜|Vn-||kr¬|Vnt d|||fƒ‚dS)a¨Remove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') addr1.address_exclude(addr2) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') addr1.address_exclude(addr2) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. z%%s and %s are not of the same versionz%s is not a network objectz%s not contained in %sz%s/%sz3Error performing exclusion: s1: %s s2: %s other: %sN) rDr3r1rLr=r>rÚ StopIterationr9r]rAÚAssertionError)rUroÚs1Ús2r r r Úaddress_excludeÑs<$    z_BaseNetwork.address_excludecCs‡|j|jkr+td||fƒ‚n|j|jkrAdS|j|jkrWdS|j|jkrmdS|j|jkrƒdSdS)a¥Compare two IP objects. This is only concerned about the comparison of the integer representation of the network addresses. This means that the host bits aren't considered at all in this method. If you want to compare host bits, you can easily enough do a 'HostA._ip < HostB._ip' Args: other: An IP object. Returns: If the IP versions of self and other are the same, returns: -1 if self < other: eg: IPv4Network('192.0.2.0/25') < IPv4Network('192.0.2.128/25') IPv6Network('2001:db8::1000/124') < IPv6Network('2001:db8::2000/124') 0 if self == other eg: IPv4Network('192.0.2.0/24') == IPv4Network('192.0.2.0/24') IPv6Network('2001:db8::1000/124') == IPv6Network('2001:db8::1000/124') 1 if self > other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. z"%s and %s are not of the same typer%rr;r;)rDr3r=r„)rUror r r Úcompare_networkss!z_BaseNetwork.compare_networkscCs|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rDr=r„)rUr r r rMOsz_BaseNetwork._get_networks_keyr%NccsL|j|jkr|VdS|dk rp||jkrEtdƒ‚n|dkr`tdƒ‚n||j}n|dkr‹tdƒ‚n|j|}||jkrÀtd||fƒ‚n|jd|j|j|fƒ}|V|}xW|j}||jkr dS|jt|ƒdƒ}|jd||fƒ}|VqñWdS) aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr%z(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %sz%s/%s)rEr5rr9r=r>r{rf)rUÚprefixlen_diffÚ new_prefixZ new_prefixlenr(Zcurrentr}Znew_addrr r r rAYs:        z_BaseNetwork.subnetscCsÝ|jdkr|S|dk rh||jkr=tdƒ‚n|dkrXtdƒ‚n|j|}n|j|dkr—td|j|fƒ‚n|jd|j|j|fdd ƒ}|jd|j|jfƒS) aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr%z(cannot set prefixlen_diff and new_prefixz;current prefixlen is %d, cannot have a prefixlen_diff of %dz%s/%drF)rErr]r9r=)rUr“r”Útr r r r@—s    z_BaseNetwork.supernetcCs|jjo|jjS)z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )r=Ú is_multicastr>)rUr r r r–Às z_BaseNetwork.is_multicastcCs|jjo|jjS)zµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )r=Ú is_reservedr>)rUr r r r—Ìs z_BaseNetwork.is_reservedcCs|jjo|jjS)z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )r=Ú is_link_localr>)rUr r r r˜Øs z_BaseNetwork.is_link_localcCs|jjo|jjS)zÔTest if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )r=Ú is_privater>)rUr r r r™ãs z_BaseNetwork.is_privatecCs|j S)z×Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )r™)rUr r r Ú is_globalïs z_BaseNetwork.is_globalcCs|jjo|jjS)z¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )r=Úis_unspecifiedr>)rUr r r r›ús z_BaseNetwork.is_unspecifiedcCs|jjo|jjS)z±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )r=Ú is_loopbackr>)rUr r r rœs z_BaseNetwork.is_loopback)$rrrrrmrtrvrr€rƒrqrpryr…r†rkr>rˆr‰rŠr‹rŒr{r]r‘r’rMrAr@r–r—r˜r™ršr›rœr r r r rLGs@          N 0 >)      rLc @s´eZdZdZdedZedƒZed!ƒZdd„Z dd„Z dd„Z dd„Z dd„Z dd„Zdd„Zedd„ƒZedd„ƒZd S)"rczyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. rr%Ú 0123456789éÿéþéüéøéðéàéÀrrcCsd|_t|_dS)Nr)rDÚ IPV4LENGTHr5)rUrr r r rm#s z_BaseV4.__init__cCs t|ƒS)N)r )rUr r r rT'sz$_BaseV4._explode_shorthand_ip_stringcCs®|stdƒ‚n|jdƒ}t|ƒdkrItd|ƒ‚ny tjt|j|ƒdƒSWn>tk r©}ztd||fƒd‚WYdd}~XnXdS)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. zAddress cannot be emptyÚ.rzExpected 4 octets in %rrz%s in %rN)rr!r"rfÚ from_bytesÚmapÚ _parse_octetr)rUriZoctetsÚexcr r r rh*s  z_BaseV4._ip_int_from_stringcCsÒ|stdƒ‚n|jj|ƒs@d}t||ƒ‚nt|ƒdkrkd}t||ƒ‚nt|dƒ}|dkr¯|ddkr¯d }t||ƒ‚n|d krÎtd |ƒ‚n|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %ré érÚ0z3Ambiguous (octal/decimal) value in %r not permittedržzOctet %d (> 255) not permitted)rrdrer"rf)rUZ octet_strrZZ octet_intr r r r©Cs  z_BaseV4._parse_octetcCs"djtt|jddƒƒƒS)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. r¦rr)Újoinr¨r r)rUr`r r r rugs z_BaseV4._string_from_ip_intcCsñ|jdƒ}t|ƒdkr­y.x'|D]}t|ƒ|jkr+dSq+WWntk rgdSYnXx>t|ƒD]0\}}|dkru|||dkrudSquWdSyt|ƒ}Wntk rÕdSYnXd|koî|jkSS)zûVerify that the netmask is valid. Args: netmask: A string, either a prefix or dotted decimal netmask. Returns: A boolean, True if the prefix represents a valid IPv4 netmask. r¦rFrr%T)r!r"rfÚ_valid_mask_octetsrÚ enumerater5)rUr„Úmaskr~ÚidxÚyr r r Ú_is_valid_netmaskss"        z_BaseV4._is_valid_netmaskc s†|jdƒ}y&‡fdd†tt|ƒDƒ}Wntk rMdSYnXt|ƒt|ƒkrjdS|d|dkr‚dSdS) zÙTest if the IP string is a hostmask (rather than a netmask). Args: ip_str: A string, the potential hostmask. Returns: A boolean, True if the IP string is a hostmask. r¦cs%g|]}|ˆjkr|‘qSr )r°)Ú.0r~)rUr r ú žs z(_BaseV4._is_hostmask..Frr%Tr;)r!r¨rfrr")rUrir-Úpartsr )rUr Ú _is_hostmask’s &  z_BaseV4._is_hostmaskcCs|jS)N)r5)rUr r r Ú max_prefixlen§sz_BaseV4.max_prefixlencCs|jS)N)rD)rUr r r r4«sz_BaseV4.versionN) ržrŸr r¡r¢r£r¤rr)rrrrr¥r8Ú frozensetrdr°rmrTrhr©rurµr¹rkrºr4r r r r rcs       $  rcc@s¬eZdZdZdd„Zedd„ƒZedd„ƒZeej ƒdd „ƒƒZ ed d „ƒZ ed d „ƒZ edd„ƒZ edd„ƒZdS)r z/Represent and manipulate single IPv4 Addresses.cCs£tj||ƒtj||ƒt|tƒrI|j|ƒ||_dSt|tƒr�|j|dƒtj |dƒ|_dSt |ƒ}|j |ƒ|_dS)a± Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. Nrr) r2rmrcr1rfr[r&rlr\r§r rh)rUrÚaddr_strr r r rm´s   zIPv4Address.__init__cCs t|jƒS)z*The binary representation of this address.)rr&)rUr r r ÚpackedØszIPv4Address.packedcCstdƒ}||kS)z°Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. z 240.0.0.0/4)r)rUZreserved_networkr r r r—Ýs zIPv4Address.is_reservedcCsú|tdƒkpù|tdƒkpù|tdƒkpù|tdƒkpù|tdƒkpù|tdƒkpù|tdƒkpù|tdƒkpù|td ƒkpù|td ƒkpù|td ƒkpù|td ƒkpù|td ƒkpù|tdƒkS)z¶Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry. z 0.0.0.0/8z 10.0.0.0/8z 127.0.0.0/8z169.254.0.0/16z 172.16.0.0/12z 192.0.0.0/29z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32)r)rUr r r r™és zIPv4Address.is_privatecCstdƒ}||kS)z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. z 224.0.0.0/4)r)rUÚmulticast_networkr r r r–s zIPv4Address.is_multicastcCstdƒ}||kS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. z0.0.0.0)r )rUZunspecified_addressr r r r›s zIPv4Address.is_unspecifiedcCstdƒ}||kS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. z 127.0.0.0/8)r)rUZloopback_networkr r r rœs zIPv4Address.is_loopbackcCstdƒ}||kS)z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. z169.254.0.0/16)r)rUÚlinklocal_networkr r r r˜&s zIPv4Address.is_link_localN)rrrrrmrkr½r—Ú functoolsÚ lru_cacher™r–r›rœr˜r r r r r °s  $    r c@s”eZdZdd„Zdd„Zdd„Zdd„Zd d „Zed d „ƒZ ed d„ƒZ edd„ƒZ edd„ƒZ dS)rcCs­t|ttfƒrGtj||ƒt|jƒ|_|j|_ dSt |ƒ}tj||dƒt|ddƒ|_|jj |_ |jj |_ |jj |_ dS)NrrF) r1rlrfr rmrr&r|r5rEr$r„rˆ)rUrr#r r r rm4s  zIPv4Interface.__init__cCs d|j|jƒ|jjfS)Nz%s/%d)rur&r|r])rUr r r rvDszIPv4Interface.__str__c CsZtj||ƒ}| s%|tkr)|Sy|j|jkSWntk rUdSYnXdS)NF)r rprPr|rF)rUroÚ address_equalr r r rpHs zIPv4Interface.__eq__c CsStj||ƒ}|tkr"tSy|j|jkSWntk rNdSYnXdS)NF)r rqrPr|rF)rUroÚ address_lessr r r rqTs  zIPv4Interface.__lt__cCs|j|jAt|jjƒAS)N)r&rErfr|r=)rUr r r ry_szIPv4Interface.__hash__cCs t|jƒS)N)r r&)rUr r r r*bszIPv4Interface.ipcCsd|j|jƒ|jfS)Nz%s/%s)rur&rE)rUr r r r‰fszIPv4Interface.with_prefixlencCsd|j|jƒ|jfS)Nz%s/%s)rur&r„)rUr r r rŠkszIPv4Interface.with_netmaskcCsd|j|jƒ|jfS)Nz%s/%s)rur&rˆ)rUr r r r‹pszIPv4Interface.with_hostmaskN) rrrrmrvrprqryrkr*r‰rŠr‹r r r r r2s    rc@sIeZdZdZeZddd„Zeej ƒdd„ƒƒZ dS)raeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 Tc CsÞtj||ƒtj||ƒt|tƒr`t|ƒ|_|j|_t|j ƒ|_ dSt|t ƒr t|ƒ|_|j|_t|j ƒ|_ dSt |ƒ}t|j |dƒƒ|_t|ƒdkr"y|j|dƒ|_Wq.tk r|j|dƒ|_Yq.Xn |j|_t|j|jƒƒ|_ |r�tt |jƒt |j ƒ@ƒ|jkr�td|ƒ‚q�ntt |jƒt |j ƒ@ƒ|_|j|jdkrÚ|j|_ndS)aInstantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.0.2/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. Nrrr%z%s has host bits set)rcrmrLr1rlr r=r5rEr8r„rfr$rhr"rgr rjr^rr€r)rUrrr#r r r rm…s:&      zIPv4Network.__init__cCs3|jtdƒko'|jtdƒk o2|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. z 100.64.0.0/10)r=rr>r™)rUr r r ršÙs zIPv4Network.is_globalN) rrrrr r{rmrkrÀrÁršr r r r rvs Trc@s¥eZdZdZdedZdZedƒZdd„Z dd „Z d d „Z d d „Z ddd„Z dd„Zedd„ƒZedd„ƒZdS)Ú_BaseV6zyBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. rr%r_Z0123456789ABCDEFabcdefcCsd|_t|_dS)Nr0)rDÚ IPV6LENGTHr5)rUrr r r rmös z_BaseV6.__init__cCsÜ|stdƒ‚n|jdƒ}d}t|ƒ|kr[d||f}t|ƒ‚nd|dkröyt|jƒƒj}Wn>tk rÄ}ztd||fƒd‚WYdd}~XnX|jd |d ?d @ƒ|jd |d @ƒn|jd}t|ƒ|kr8d |d|f}t|ƒ‚nd}xYtdt|ƒdƒD]>} || sX|dk r�d |}t|ƒ‚n| }qXqXW|dk rr|} t|ƒ|d} |dsö| d8} | röd}t||ƒ‚qön|ds,| d8} | r,d}t||ƒ‚q,n|j| | } | dkrd}t||jd|fƒ‚qn•t|ƒ|jkr©d}t||j|fƒ‚n|dsÌd}t||ƒ‚n|dsïd}t||ƒ‚nt|ƒ} d} d} y�d} x5t| ƒD]'} | d K} | |j || ƒO} qW| d | K} x9t| dƒD]'} | d K} | |j || ƒO} qgW| SWn>t k r×}ztd||fƒd‚WYdd}~XnXdS)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. zAddress cannot be emptyú:r«z At least %d parts expected in %rr¦r%z%s in %rNz%xriÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %rr;r;r;) rr!r"r Úpopr&r<Ú _HEXTET_COUNTr,Ú _parse_hextetr)rUrir¸Z _min_partsrZZipv4_intrªZ _max_partsZ skip_indexr.Zparts_hiZparts_loZ parts_skippedr`r r r rhús„ ,            #     z_BaseV6._ip_int_from_stringcCs]|jj|ƒs%td|ƒ‚nt|ƒdkrPd}t||ƒ‚nt|dƒS)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr)Ú _HEX_DIGITSrerr"rf)rUZ hextet_strrZr r r rÉas z_BaseV6._parse_hextetc Csød}d}d}d}xot|ƒD]a\}}|dkrz|d7}|dkr\|}n||kr†|}|}q†q%d}d}q%W|dkrô||}|t|ƒkrÂ|dg7}ndg|||…<|dkrôdg|}qôn|S) aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. r%rr®Úr;r;r;r;)r±r") rUÚhextetsZbest_doublecolon_startZbest_doublecolon_lenZdoublecolon_startZdoublecolon_lenrIZhextetZbest_doublecolon_endr r r Ú_compress_hextetszs.         z_BaseV6._compress_hextetsNcs‡|dkrt|jƒ}n||jkr<tdƒ‚nd|‰‡fdd†tdddƒDƒ}|j|ƒ}d j|ƒS) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largez%032xcs1g|]'}dtˆ||d…dƒ‘qS)z%xrr)rf)r¶r~)Úhex_strr r r·½s z/_BaseV6._string_from_ip_int..rrrrÆ)rfr&r8rr,rÍr¯)rUr`rÌr )rÎr ru©s  %z_BaseV6._string_from_ip_intcsÈt|tƒr!t|jƒ}n-t|tƒrBt|jƒ}n t|ƒ}|j|ƒ}d|‰‡fdd†tdddƒDƒ}t|ttfƒr»ddj |ƒ|j fSdj |ƒS) z¬Expand a shortened IPv6 address. Args: ip_str: A string, the IPv6 address. Returns: A string, the expanded IPv6 address. z%032xcs$g|]}ˆ||d…‘qS)rr )r¶r~)rÎr r r·Õs z8_BaseV6._explode_shorthand_ip_string..rrrz%s/%drÆ) r1rr r=rr*rhr,rLr¯rE)rUrir`r¸r )rÎr rTÂs   %z$_BaseV6._explode_shorthand_ip_stringcCs|jS)N)r5)rUr r r rºÚsz_BaseV6.max_prefixlencCs|jS)N)rD)rUr r r r4Þsz_BaseV6.version)rrrrrÅr8rÈr»rÊrmrhrÉrÍrurTrkrºr4r r r r rÄés    g  / rÄc@seZdZdZdd„Zedd„ƒZedd„ƒZedd „ƒZed d „ƒZ ed d „ƒZ ee j ƒdd„ƒƒZ edd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZdS)r z/Represent and manipulate single IPv6 Addresses.cCs£tj||ƒtj||ƒt|tƒrI|j|ƒ||_dSt|tƒr�|j|dƒtj |dƒ|_dSt |ƒ}|j |ƒ|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nrr) r2rmrÄr1rfr[r&rlr\r§r rh)rUrr¼r r r rmçs   zIPv6Address.__init__cCs t|jƒS)z*The binary representation of this address.)rr&)rUr r r r½ szIPv6Address.packedcCstdƒ}||kS)z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. zff00::/8)r)rUr¾r r r r–s zIPv6Address.is_multicastcsªtdƒtdƒtdƒtdƒtdƒtdƒtdƒtdƒtd ƒtd ƒtd ƒtd ƒtd ƒtdƒtdƒg}t‡fdd†|DƒƒS)zµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9c3s|]}ˆ|kVqdS)Nr )r¶r~)rUr r ú /sz*IPv6Address.is_reserved..)rÚany)rUZreserved_networksr )rUr r—s zIPv6Address.is_reservedcCstdƒ}||kS)z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. z fe80::/10)r)rUr¿r r r r˜1s zIPv6Address.is_link_localcCstdƒ}||kS)a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. z fec0::/10)r)rUZsitelocal_networkr r r Ú is_site_local<s zIPv6Address.is_site_localcCs²|tdƒkp±|tdƒkp±|tdƒkp±|tdƒkp±|tdƒkp±|tdƒkp±|tdƒkp±|tdƒkp±|td ƒkp±|td ƒkS) z¶Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv6-special-registry. z::1/128z::/128z ::ffff:0:0/96z100::/64z 2001::/23z 2001:2::/48z 2001:db8::/32z 2001:10::/28zfc00::/7z fe80::/10)r)rUr r r r™Ks zIPv6Address.is_privatecCs|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, true if the address is not reserved per iana-ipv6-special-registry. )r™)rUr r r rš`s zIPv6Address.is_globalcCs |jdkS)z¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. r)r&)rUr r r r›ks zIPv6Address.is_unspecifiedcCs |jdkS)z±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. r%)r&)rUr r r rœvs zIPv6Address.is_loopbackcCs(|jd?dkrdSt|jd@ƒS)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. riÿÿNlÿÿ)r&r )rUr r r Ú ipv4_mapped�s zIPv6Address.ipv4_mappedcCs@|jd?dkrdSt|jd?d@ƒt|jd@ƒfS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@lÿÿ)r&r )rUr r r ÚteredoŽs zIPv6Address.teredocCs,|jd?dkrdSt|jd?d@ƒS)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPlÿÿ)r&r )rUr r r Ú sixtofour�s zIPv6Address.sixtofourN)rrrrrmrkr½r–r—r˜rÑrÀrÁr™ršr›rœrÒrÕrØr r r r r ãs  %      r c@s¸eZdZdd„Zdd„Zdd„Zdd„Zd d „Zed d „ƒZ ed d„ƒZ edd„ƒZ edd„ƒZ edd„ƒZ edd„ƒZdS)rcCs­t|ttfƒrGtj||ƒt|jƒ|_|j|_ dSt |ƒ}tj||dƒt|ddƒ|_|jj |_ |jj |_ |jj |_ dS)NrrF) r1rlrfr rmrr&r|r5rEr$r„rˆ)rUrr#r r r rm­s  zIPv6Interface.__init__cCs d|j|jƒ|jjfS)Nz%s/%d)rur&r|r])rUr r r rv»szIPv6Interface.__str__c CsZtj||ƒ}| s%|tkr)|Sy|j|jkSWntk rUdSYnXdS)NF)r rprPr|rF)rUrorÂr r r rp¿s zIPv6Interface.__eq__c CsStj||ƒ}|tkr"tSy|j|jkSWntk rNdSYnXdS)NF)r rqrPr|rF)rUrorÃr r r rqËs  zIPv6Interface.__lt__cCs|j|jAt|jjƒAS)N)r&rErfr|r=)rUr r r ryÖszIPv6Interface.__hash__cCs t|jƒS)N)r r&)rUr r r r*ÙszIPv6Interface.ipcCsd|j|jƒ|jfS)Nz%s/%s)rur&rE)rUr r r r‰ÝszIPv6Interface.with_prefixlencCsd|j|jƒ|jfS)Nz%s/%s)rur&r„)rUr r r rŠâszIPv6Interface.with_netmaskcCsd|j|jƒ|jfS)Nz%s/%s)rur&rˆ)rUr r r r‹çszIPv6Interface.with_hostmaskcCs|jdko|jjS)Nr)r&r|r›)rUr r r r›ìszIPv6Interface.is_unspecifiedcCs|jdko|jjS)Nr%)r&r|rœ)rUr r r rœðszIPv6Interface.is_loopbackN)rrrrmrvrprqryrkr*r‰rŠr‹r›rœr r r r r«s    rc@sIeZdZdZeZddd„Zdd„Zedd„ƒZ d S) ravThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 TcCs¯tj||ƒtj||ƒt|tƒr`t|ƒ|_|j|_t|j ƒ|_ dSt|t ƒr t|ƒ|_|j|_t|j ƒ|_ dSt |ƒ}t|j |dƒƒ|_t|ƒdkró|j|dƒ|_n |j|_t|j|jƒƒ|_ |ratt|jƒt|j ƒ@ƒ|jkratd|ƒ‚qantt|jƒt|j ƒ@ƒ|_|j|jdkr«|j|_ndS)açInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. Nrrr%z%s has host bits set)rÄrmrLr1rfr r=r5rEr8r„rlr$rhr"rgr^rr€r)rUrrr#r r r rms4      zIPv6Network.__init__ccsRt|jƒ}t|jƒ}x-t|d|dƒD]}|j|ƒVq6WdS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r%N)rfr=r>r,r{)rUr|r}r~r r r rMszIPv6Network.hostscCs|jjo|jjS)a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )r=rÑr>)rUr r r rÑYs zIPv6Network.is_site_localN) rrrrr r{rmrrkrÑr r r r rõs H r) rÚ __version__rÀr¥rÅrrr rrrrrr$r+r/r:rBrNrRrSÚtotal_orderingr2rLrcr rrrÄr rrr r r r Ú s@   #      8 0 9 … : ÿÌ�‚DsúÈJ